• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>
            posts - 195,  comments - 30,  trackbacks - 0

            Your teacher has given you some problems to solve. You must first solve problem 0. After solving each problem i, you must either move on to problem i+1 or skip ahead to problem i+2. You are not allowed to skip more than one problem. For example, {0, 2, 3, 5} is a valid order, but {0, 2, 4, 7} is not because the skip from 4 to 7 is too long.

            You are given N integers, where the ith integer indicates how much you like problem i. The teacher will let you stop solving problems once the range of pleasantness you've encountered reaches a certain threshold. Specifically, you may stop once the difference between the maximum and minimum pleasantness of the problems you've solved is greater than or equal to a integer K. If this never happens, you must solve all the problems.

            Input

            The input contains several test cases. For each case it contains two positive integer N, K (1<=N<=50, 1<=K<=1000), then N integers follow in the next line, the ith integer ( >=1 and <= 1000 ) indicates how much you like problem i.

            Output

            For each test case, output the minimum number of problems you must solve to satisfy the teacher's requirements.

            Sample Input

            3 2
            1 2 3
            5 4
            1 2 3 4 5

            Sample Output

            2
            3
            很笨但是很實用!
            #include<stdio.h>
            int a[51];
            int main()
            {
            int n,k;
            while(scanf("%d%d",&n,&k)!=EOF)
            {
            int i,j;
            for(i=0;i<n;i++)
            scanf("%d",a+i);
            int min=0xfffffff;
            int flag=0;
            for(i=1;i<n;i++)
            for(j=0;j<i;j++)
            {
            if(a[i]-a[j]>=k||a[j]-a[i]>=k)
            {
            flag=1;
            int step;
            if(j==0)
            {
            step=(i+1)/2+1;
            if(min>step)
            min=step;
            }
            else
            {
            step=(i-j+1)/2+(j+1)/2+1;
            if(min>step)
            min=step;
            }
            }
            }
            if(flag)
            printf("%d\n",min);
            else
            printf("%d\n",n);
            }
            return 0;
            }
            posted on 2009-06-28 22:26 luis 閱讀(247) 評論(0)  編輯 收藏 引用 所屬分類: 給我啟發題
            <2009年7月>
            2829301234
            567891011
            12131415161718
            19202122232425
            2627282930311
            2345678

            常用鏈接

            留言簿(3)

            隨筆分類

            隨筆檔案

            文章分類

            文章檔案

            友情鏈接

            搜索

            •  

            最新評論

            閱讀排行榜

            評論排行榜

            99精品久久精品| 欧美精品九九99久久在观看| 中文字幕乱码人妻无码久久| 久久久亚洲裙底偷窥综合 | 免费精品国产日韩热久久| 香蕉久久夜色精品国产2020 | 久久久久人妻精品一区三寸蜜桃| 久久99精品久久久久久噜噜| 久久久久亚洲精品日久生情| 青青草原综合久久大伊人精品| 久久精品99无色码中文字幕| 久久亚洲欧美国产精品| 精品久久久久中文字幕一区| 777午夜精品久久av蜜臀| 国产激情久久久久影院| 久久永久免费人妻精品下载| 久久久人妻精品无码一区| 性欧美大战久久久久久久久 | 亚洲精品午夜国产va久久| 久久精品国产半推半就| 人妻少妇久久中文字幕| 久久有码中文字幕| 久久99精品久久久久久秒播| 久久AV高清无码| 人妻精品久久久久中文字幕69| 久久亚洲AV无码西西人体| 成人国内精品久久久久影院VR| 伊人久久大香线蕉av不卡| 97精品伊人久久大香线蕉| 亚洲精品国精品久久99热| 久久久久国产| 中文字幕精品久久| 99久久综合国产精品免费| 综合久久精品色| 精品久久久中文字幕人妻| 久久免费看黄a级毛片| 国内高清久久久久久| 亚洲AV日韩AV永久无码久久| 大香伊人久久精品一区二区| 久久国产欧美日韩精品| 久久久久波多野结衣高潮|