• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>
            posts - 195,  comments - 30,  trackbacks - 0

            Your teacher has given you some problems to solve. You must first solve problem 0. After solving each problem i, you must either move on to problem i+1 or skip ahead to problem i+2. You are not allowed to skip more than one problem. For example, {0, 2, 3, 5} is a valid order, but {0, 2, 4, 7} is not because the skip from 4 to 7 is too long.

            You are given N integers, where the ith integer indicates how much you like problem i. The teacher will let you stop solving problems once the range of pleasantness you've encountered reaches a certain threshold. Specifically, you may stop once the difference between the maximum and minimum pleasantness of the problems you've solved is greater than or equal to a integer K. If this never happens, you must solve all the problems.

            Input

            The input contains several test cases. For each case it contains two positive integer N, K (1<=N<=50, 1<=K<=1000), then N integers follow in the next line, the ith integer ( >=1 and <= 1000 ) indicates how much you like problem i.

            Output

            For each test case, output the minimum number of problems you must solve to satisfy the teacher's requirements.

            Sample Input

            3 2
            1 2 3
            5 4
            1 2 3 4 5

            Sample Output

            2
            3
            很笨但是很實用!
            #include<stdio.h>
            int a[51];
            int main()
            {
            int n,k;
            while(scanf("%d%d",&n,&k)!=EOF)
            {
            int i,j;
            for(i=0;i<n;i++)
            scanf("%d",a+i);
            int min=0xfffffff;
            int flag=0;
            for(i=1;i<n;i++)
            for(j=0;j<i;j++)
            {
            if(a[i]-a[j]>=k||a[j]-a[i]>=k)
            {
            flag=1;
            int step;
            if(j==0)
            {
            step=(i+1)/2+1;
            if(min>step)
            min=step;
            }
            else
            {
            step=(i-j+1)/2+(j+1)/2+1;
            if(min>step)
            min=step;
            }
            }
            }
            if(flag)
            printf("%d\n",min);
            else
            printf("%d\n",n);
            }
            return 0;
            }
            posted on 2009-06-28 22:26 luis 閱讀(247) 評論(0)  編輯 收藏 引用 所屬分類: 給我啟發題
            <2009年7月>
            2829301234
            567891011
            12131415161718
            19202122232425
            2627282930311
            2345678

            常用鏈接

            留言簿(3)

            隨筆分類

            隨筆檔案

            文章分類

            文章檔案

            友情鏈接

            搜索

            •  

            最新評論

            閱讀排行榜

            評論排行榜

            大伊人青草狠狠久久| 久久精品成人欧美大片 | 日韩精品无码久久久久久| 久久精品国产99国产精品亚洲| 色诱久久av| 久久99热国产这有精品| 99久久亚洲综合精品网站| 日本高清无卡码一区二区久久| 欧美久久综合性欧美| 久久九九兔免费精品6| 亚洲国产精品18久久久久久| 国内精品久久久久久久久| 久久Av无码精品人妻系列 | 亚洲综合伊人久久综合| 国产高清美女一级a毛片久久w | 久久久人妻精品无码一区| 久久精品国产亚洲精品2020| 韩国无遮挡三级久久| 亚洲综合久久夜AV | 久久强奷乱码老熟女网站| 97精品伊人久久久大香线蕉| 久久美女人爽女人爽| 久久人与动人物a级毛片| 99久久精品久久久久久清纯| 国产激情久久久久久熟女老人 | 99麻豆久久久国产精品免费| 久久精品二区| 久久综合九色综合97_久久久| 久久亚洲精品国产亚洲老地址| 91麻精品国产91久久久久| 亚洲人成伊人成综合网久久久| 久久综合狠狠综合久久激情 | 久久综合丁香激情久久| 成人午夜精品无码区久久| 欧美久久久久久精选9999| 久久精品国产99国产电影网 | 久久久久亚洲av成人无码电影| 国产精品久久久久9999高清| 欧美精品国产综合久久| 蜜臀av性久久久久蜜臀aⅴ麻豆| 久久精品亚洲男人的天堂|