• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>
            posts - 14,  comments - 11,  trackbacks - 0
            Problem Description
            RSA is one of the most powerful methods to encrypt data. The RSA algorithm is described as follow:

            > choose two large prime integer p, q
            > calculate n = p × q, calculate F(n) = (p - 1) × (q - 1)
            > choose an integer e(1 < e < F(n)), making gcd(e, F(n)) = 1, e will be the public key
            > calculate d, making d × e mod F(n) = 1 mod F(n), and d will be the private key

            You can encrypt data with this method :

            C = E(m) = me mod n

            When you want to decrypt data, use this method :

            M = D(c) = cd mod n

            Here, c is an integer ASCII value of a letter of cryptograph and m is an integer ASCII value of a letter of plain text.

            Now given p, q, e and some cryptograph, your task is to "translate" the cryptograph into plain text.
             

            Input
            Each case will begin with four integers p, q, e, l followed by a line of cryptograph. The integers p, q, e, l will be in the range of 32-bit integer. The cryptograph consists of l integers separated by blanks.
             

            Output
            For each case, output the plain text in a single line. You may assume that the correct result of plain text are visual ASCII letters, you should output them as visualable letters with no blank between them.
             

            Sample Input
            101 103 7 11 7716 7746 7497 126 8486 4708 7746 623 7298 7357 3239
             

            Sample Output
            I-LOVE-ACM.
            以為要數組,想想,不是那么回事!

            挺簡單的~~
             1 #include<iostream>
             2 using namespace std;
             3 int main(){
             4     int p,q,e,t;
             5     while (cin>>p>>q>>e>>t)
             6     {
             7            int n = p*q,fn = (p-1)*(q-1);
             8            int d =1;
             9            while ((d*e)%fn!=1)d++;
            10           int c;
            11           for (int i=0;i<t;i++)
            12           {
            13                  cin>>c;
            14                  int temp=1;
            15                  for (int j=1;j<=d;j++)
            16                  {
            17                      temp*=c;
            18                      temp%=n;
            19                   }
            20                 cout<<char(temp); 
            21                  }
            22            cout<<endl;
            23            }    
            24     return 0;
            25     }
            posted on 2010-06-26 18:59 路修遠 閱讀(464) 評論(0)  編輯 收藏 引用
            <2025年5月>
            27282930123
            45678910
            11121314151617
            18192021222324
            25262728293031
            1234567

            轉載,請標明出處!謝謝~~

            常用鏈接

            留言簿(1)

            隨筆分類

            隨筆檔案

            文章檔案

            搜索

            •  

            最新評論

            • 1.?re: HDU 2433 最短路
            • @test
              的確這組數據應該輸出20的
            • --YueYueZha
            • 2.?re: HDU 2433 最短路
            • 這方法應該不對。 看下面這組數據
              4 4
              1 2
              2 3
              3 4
              2 4

              畫個圖,刪去最后一條邊 2 4 后的結果應該是20,但是此方法的輸出是19
            • --test
            • 3.?re: HDU 2433 最短路
            • ans = ans + sum_u + sum_v - sum[u] - sum[v],
              這個公式不是很理解啊,不知道博主怎么想的啊,謝謝咯
            • --姜
            • 4.?re: HDU 2433 最短路
            • @attacker
              the i-th line is the new SUM after the i-th road is destroyed
            • --路修遠
            • 5.?re: HDU 2433 最短路
            • 你這樣可以AC????刪除<U,V>不僅改變 u,v最短路啊、、、求解
            • --attacker

            閱讀排行榜

            評論排行榜

            精品永久久福利一区二区| 波多野结衣久久| 亚洲AV乱码久久精品蜜桃| 久久午夜综合久久| 久久久久免费视频| 91久久精品国产91性色也| 久久久青草久久久青草| 久久久久国产一级毛片高清版| 日本一区精品久久久久影院| 久久精品男人影院| 国产成人精品综合久久久| 久久er国产精品免费观看8| 99热精品久久只有精品| 国产真实乱对白精彩久久| 久久亚洲国产精品123区| 伊人色综合久久天天网| 亚洲色大成网站www久久九| 久久天天躁狠狠躁夜夜网站| 亚洲国产精品高清久久久| 久久国产精品一国产精品金尊| 国产综合久久久久| 久久国产精品一区| 亚洲国产成人精品女人久久久 | 久久99精品久久久久久不卡 | 久久久99精品成人片中文字幕 | 久久精品国产AV一区二区三区| 伊人久久大香线蕉亚洲| 精品免费tv久久久久久久| 久久精品国产一区二区三区| 久久婷婷色香五月综合激情| 久久天堂AV综合合色蜜桃网 | 91久久成人免费| 少妇无套内谢久久久久| 国产成人无码久久久精品一| 精品多毛少妇人妻AV免费久久 | 亚洲精品成人网久久久久久| 少妇久久久久久久久久| 国产精品美女久久久免费| 久久永久免费人妻精品下载| 精品久久久久久国产三级| 潮喷大喷水系列无码久久精品 |