• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>
            posts - 14,  comments - 11,  trackbacks - 0
            Problem Description
            RSA is one of the most powerful methods to encrypt data. The RSA algorithm is described as follow:

            > choose two large prime integer p, q
            > calculate n = p × q, calculate F(n) = (p - 1) × (q - 1)
            > choose an integer e(1 < e < F(n)), making gcd(e, F(n)) = 1, e will be the public key
            > calculate d, making d × e mod F(n) = 1 mod F(n), and d will be the private key

            You can encrypt data with this method :

            C = E(m) = me mod n

            When you want to decrypt data, use this method :

            M = D(c) = cd mod n

            Here, c is an integer ASCII value of a letter of cryptograph and m is an integer ASCII value of a letter of plain text.

            Now given p, q, e and some cryptograph, your task is to "translate" the cryptograph into plain text.
             

            Input
            Each case will begin with four integers p, q, e, l followed by a line of cryptograph. The integers p, q, e, l will be in the range of 32-bit integer. The cryptograph consists of l integers separated by blanks.
             

            Output
            For each case, output the plain text in a single line. You may assume that the correct result of plain text are visual ASCII letters, you should output them as visualable letters with no blank between them.
             

            Sample Input
            101 103 7 11 7716 7746 7497 126 8486 4708 7746 623 7298 7357 3239
             

            Sample Output
            I-LOVE-ACM.
            以為要數組,想想,不是那么回事!

            挺簡單的~~
             1 #include<iostream>
             2 using namespace std;
             3 int main(){
             4     int p,q,e,t;
             5     while (cin>>p>>q>>e>>t)
             6     {
             7            int n = p*q,fn = (p-1)*(q-1);
             8            int d =1;
             9            while ((d*e)%fn!=1)d++;
            10           int c;
            11           for (int i=0;i<t;i++)
            12           {
            13                  cin>>c;
            14                  int temp=1;
            15                  for (int j=1;j<=d;j++)
            16                  {
            17                      temp*=c;
            18                      temp%=n;
            19                   }
            20                 cout<<char(temp); 
            21                  }
            22            cout<<endl;
            23            }    
            24     return 0;
            25     }
            posted on 2010-06-26 18:59 路修遠 閱讀(464) 評論(0)  編輯 收藏 引用
            <2010年6月>
            303112345
            6789101112
            13141516171819
            20212223242526
            27282930123
            45678910

            轉載,請標明出處!謝謝~~

            常用鏈接

            留言簿(1)

            隨筆分類

            隨筆檔案

            文章檔案

            搜索

            •  

            最新評論

            • 1.?re: HDU 2433 最短路
            • @test
              的確這組數據應該輸出20的
            • --YueYueZha
            • 2.?re: HDU 2433 最短路
            • 這方法應該不對。 看下面這組數據
              4 4
              1 2
              2 3
              3 4
              2 4

              畫個圖,刪去最后一條邊 2 4 后的結果應該是20,但是此方法的輸出是19
            • --test
            • 3.?re: HDU 2433 最短路
            • ans = ans + sum_u + sum_v - sum[u] - sum[v],
              這個公式不是很理解啊,不知道博主怎么想的啊,謝謝咯
            • --姜
            • 4.?re: HDU 2433 最短路
            • @attacker
              the i-th line is the new SUM after the i-th road is destroyed
            • --路修遠
            • 5.?re: HDU 2433 最短路
            • 你這樣可以AC????刪除<U,V>不僅改變 u,v最短路啊、、、求解
            • --attacker

            閱讀排行榜

            評論排行榜

            久久亚洲国产最新网站| 亚洲va久久久噜噜噜久久狠狠| 日韩精品久久久肉伦网站| 亚洲午夜久久久久妓女影院| 久久精品国产第一区二区三区 | 亚洲欧美成人久久综合中文网 | 国产精品一区二区久久精品涩爱| 亚洲综合久久夜AV | 久久久久成人精品无码中文字幕 | 蜜臀久久99精品久久久久久| 亚洲午夜久久久久久久久久| 草草久久久无码国产专区| 中文字幕人妻色偷偷久久| 国产精品99久久久久久www| 一本色道久久88—综合亚洲精品| 94久久国产乱子伦精品免费 | 99热成人精品免费久久| 99久久国产综合精品女同图片| 欧美精品一本久久男人的天堂| 波多野结衣久久精品| 国产精品九九久久精品女同亚洲欧美日韩综合区 | 狠狠综合久久综合中文88| 伊人久久久AV老熟妇色| 亚洲国产综合久久天堂| 99久久精品九九亚洲精品| 国产精品久久久久国产A级| 青青草原综合久久大伊人| 一本大道久久a久久精品综合| 久久无码人妻一区二区三区| 久久亚洲精品国产精品婷婷| 久久精品国产亚洲7777| 97精品国产97久久久久久免费| 亚洲欧美日韩中文久久| 狠狠色婷婷久久综合频道日韩| 久久国产乱子伦精品免费午夜| 久久精品国产99国产精品澳门| 久久久久久精品久久久久| 亚洲国产精品无码久久98| 久久久久高潮毛片免费全部播放| 久久综合九色综合网站| 久久久这里只有精品加勒比|