• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>
            posts - 21, comments - 2, trackbacks - 0, articles - 0

            HDU 1087 Super Jumping

            Posted on 2011-10-03 01:28 acpeng 閱讀(292) 評論(0)  編輯 收藏 引用 所屬分類: ACM程序
            題目鏈接:http://acm.hdu.edu.cn/showproblem.php?pid=1087
            Problem Description
            Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.


            The game can be played by two or more than two players. It consists of a chessboard(棋盤)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
            Your task is to output the maximum value according to the given chessmen list.
            Input
            Input contains multiple test cases. Each test case is described in a line as follow:
            N value_1 value_2 …value_N
            It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
            A test case starting with 0 terminates the input and this test case is not to be processed.
            Output
            For each case, print the maximum according to rules, and one line one case.

            Sample Input
            3 1 3 2 4 1 2 3 4 4 3 3 2 1 0
            Sample Output
            4 10 3













            典型的入門級DP題,解題思路:
            定義MaxIncludeEnd數(shù)組,令MaxIncludeEnd[i]表示以a[i]結尾的最大和,那么
            MaxIncludeEnd[i]=max{ MaxIncludeEnd[i] , a[j]<a[i] ? (MaxIncludeEnd[j]+a[i]) :-1; }
            其中j=0 to i-1;MaxIncludeEnd[i]的初始值為a[i]。
            #include<stdio.h>
            int a[1003],MaxIncludeEnd[1003];
            int main()
            {
                
            int n,max,i,j;
                
            while(scanf("%d",&n),n)
                
            {
                    
            for(i=0;i<n;i++)
                    
            {
                        scanf(
            "%d",&a[i]);
                        MaxIncludeEnd[i]
            =a[i];
                    }

                    max
            =MaxIncludeEnd[0];
                    
            for(i=0;i<n;i++)
                    
            {
                        
            for(j=0;j<i;j++)
                        
            {
                            
            if(a[j]<a[i] && MaxIncludeEnd[j]+a[i]>MaxIncludeEnd[i])
                                MaxIncludeEnd[i]
            =MaxIncludeEnd[j]+a[i];
                        }

                        
            if(max<MaxIncludeEnd[i])max=MaxIncludeEnd[i];
                    }

                    printf(
            "%d\n",max);
                }

                
            return 0;
            }



            色偷偷88欧美精品久久久| 乱亲女H秽乱长久久久| 777久久精品一区二区三区无码| 91亚洲国产成人久久精品| 中文字幕亚洲综合久久2| 久久久久国产| 国产精品熟女福利久久AV| 久久99精品国产自在现线小黄鸭| 欧美伊人久久大香线蕉综合69 | 亚洲精品乱码久久久久久久久久久久 | 久久国产精品99精品国产987| 久久人人爽人人爽人人片av麻烦| 久久精品国产亚洲网站| 亚洲日本va午夜中文字幕久久| 成人a毛片久久免费播放| 久久久久se色偷偷亚洲精品av| 国产精品久久自在自线观看| AV无码久久久久不卡网站下载 | 一本久道久久综合狠狠躁AV| 国产精品一久久香蕉国产线看 | 无码任你躁久久久久久| 久久精品国产99国产电影网| 色欲久久久天天天综合网| 无码乱码观看精品久久| 99久久国产免费福利| 久久久久久久尹人综合网亚洲| 国产成年无码久久久久毛片| 成人综合久久精品色婷婷| 亚洲精品乱码久久久久久| 午夜福利91久久福利| 久久影视国产亚洲| 伊人久久综合成人网| 久久er热视频在这里精品| 久久精品国产亚洲AV麻豆网站| 91久久精品国产成人久久| 国产国产成人精品久久| AAA级久久久精品无码片| 国产亚洲婷婷香蕉久久精品| 久久精品国产亚洲av日韩| 91精品国产乱码久久久久久| 国产精品久久久久影院色|