• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>
            posts - 21, comments - 2, trackbacks - 0, articles - 0

            POJ 2273 An Excel-lent Problem

            Posted on 2011-09-05 21:53 acpeng 閱讀(480) 評論(0)  編輯 收藏 引用 所屬分類: ACM程序

            把整數轉化為excel對應的列值http://poj.org/problem?id=2273
            Description

            A certain spreadsheet program labels the columns of a spreadsheet using letters. Column 1 is labeled as ``A", column 2 as ``B", ..., column 26 as ``Z". When the number of columns is greater than 26, another letter is used. For example, column 27 is ``AA", column 28 is ``AB" and column 52 is ``AZ". It follows that column 53 would be ``BA" and so on. Similarly, when column ``ZZ" is reached, the next column would be ``AAA", then ``AAB" and so on.

            The rows in the spreadsheet are labeled using the row number. Rows start at 1.

            The designation for a particular cell within the spreadsheet is created by combining the column label with the row label. For example, the upper-left most cell would be ``A1". The cell at column 55 row 23 would be ``BC23".

            You will write a program that converts numeric row and column values into the spreadsheet designation.

            Input

            Input consists of lines of the form: RnCm. n represents the row number [1,300000000] and m represents the column number, 1<=m<=300000000. The values n and m define a single cell on the spreadsheet. Input terminates with the line: R0C0 (that is, n and m are 0). There will be no leading zeroes or extra spaces in the input.

            Output

            For each line of input (except the terminating line), you will print out the spreadsheet designation for the specified cell as described above.

            Sample Input

            R1C1
            R3C1
            R1C3
            R299999999C26
            R52C52
            R53C17576
            R53C17602
            R0C0
            

            Sample Output

            A1
            A3
            C1
            Z299999999
            AZ52
            YYZ53
            YZZ53
            

            Source

            Greater New York 2004

            進制轉化問題,把列數改成26進制輸出,分別用A,B...Z代替1,2,3...這里base[0]='Z',表示n與26余數為0時的取值,但進位問題需要注意,分余數是否為0兩種情況分析。
            代碼:
            #include<stdio.h>
            #define R 26
            char base[30]="ZABCDEFGHIJKLMNOPQRSTUVWXYZ";
            void fun(int N)
            {
                
            int i=0,j; char str[10];
                
            while(N>R)
                
            {
                    str[i
            ++]=base[N%R];
                    N
            =N%R==0?N/R-1:N/R;
                }

                str[i]
            =base[N];
                
            for(j=i;j>=0;j--)
                    printf(
            "%c",str[j]);
            }

            int main()
            {
                
            int m,n;
                
            while(scanf("%*c%d%*c%d",&m,&n)!=EOF)
                
            {
                    getchar();
                    
            if(m==0 && n==0)break;
                    fun(n);
                    printf(
            "%d\n",m);
                }

                
            return 0;
            }

            波多野结衣中文字幕久久| 精品国产乱码久久久久久呢| 成人国内精品久久久久一区| 99久久综合国产精品二区| 久久久久无码中| 久久国产热精品波多野结衣AV| 国内精品久久久久国产盗摄| 久久久精品久久久久影院| 国内精品久久久久影院优| 日本久久中文字幕| 久久se精品一区二区| 婷婷久久五月天| 国产毛片久久久久久国产毛片| 国产精品99久久久精品无码| 精品国产一区二区三区久久蜜臀| 欧美va久久久噜噜噜久久| 久久国产成人精品国产成人亚洲| 久久er99热精品一区二区| 久久久久99这里有精品10| 国产精品久久久久久久久久免费| 亚洲狠狠婷婷综合久久蜜芽| 久久一区二区三区99| 99久久无码一区人妻| 久久本道伊人久久| 国内精品伊人久久久久AV影院| 久久久久久精品久久久久| 日韩久久久久中文字幕人妻| 久久精品国产72国产精福利| 国内精品久久久久久麻豆| 国产一级持黄大片99久久| 国内精品久久久久影院优| 久久精品一本到99热免费| 人妻精品久久久久中文字幕69| 久久综合亚洲色HEZYO社区 | 久久精品国产亚洲Aⅴ香蕉 | 亚洲精品乱码久久久久久蜜桃图片 | 四虎国产精品免费久久5151| 国产精品久久久久无码av| 国产高潮国产高潮久久久| 久久99免费视频| 久久久久久噜噜精品免费直播|