• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>
            posts - 21, comments - 2, trackbacks - 0, articles - 0

            POJ 2273 An Excel-lent Problem

            Posted on 2011-09-05 21:53 acpeng 閱讀(481) 評論(0)  編輯 收藏 引用 所屬分類: ACM程序

            把整數轉化為excel對應的列值http://poj.org/problem?id=2273
            Description

            A certain spreadsheet program labels the columns of a spreadsheet using letters. Column 1 is labeled as ``A", column 2 as ``B", ..., column 26 as ``Z". When the number of columns is greater than 26, another letter is used. For example, column 27 is ``AA", column 28 is ``AB" and column 52 is ``AZ". It follows that column 53 would be ``BA" and so on. Similarly, when column ``ZZ" is reached, the next column would be ``AAA", then ``AAB" and so on.

            The rows in the spreadsheet are labeled using the row number. Rows start at 1.

            The designation for a particular cell within the spreadsheet is created by combining the column label with the row label. For example, the upper-left most cell would be ``A1". The cell at column 55 row 23 would be ``BC23".

            You will write a program that converts numeric row and column values into the spreadsheet designation.

            Input

            Input consists of lines of the form: RnCm. n represents the row number [1,300000000] and m represents the column number, 1<=m<=300000000. The values n and m define a single cell on the spreadsheet. Input terminates with the line: R0C0 (that is, n and m are 0). There will be no leading zeroes or extra spaces in the input.

            Output

            For each line of input (except the terminating line), you will print out the spreadsheet designation for the specified cell as described above.

            Sample Input

            R1C1
            R3C1
            R1C3
            R299999999C26
            R52C52
            R53C17576
            R53C17602
            R0C0
            

            Sample Output

            A1
            A3
            C1
            Z299999999
            AZ52
            YYZ53
            YZZ53
            

            Source

            Greater New York 2004

            進制轉化問題,把列數改成26進制輸出,分別用A,B...Z代替1,2,3...這里base[0]='Z',表示n與26余數為0時的取值,但進位問題需要注意,分余數是否為0兩種情況分析。
            代碼:
            #include<stdio.h>
            #define R 26
            char base[30]="ZABCDEFGHIJKLMNOPQRSTUVWXYZ";
            void fun(int N)
            {
                
            int i=0,j; char str[10];
                
            while(N>R)
                
            {
                    str[i
            ++]=base[N%R];
                    N
            =N%R==0?N/R-1:N/R;
                }

                str[i]
            =base[N];
                
            for(j=i;j>=0;j--)
                    printf(
            "%c",str[j]);
            }

            int main()
            {
                
            int m,n;
                
            while(scanf("%*c%d%*c%d",&m,&n)!=EOF)
                
            {
                    getchar();
                    
            if(m==0 && n==0)break;
                    fun(n);
                    printf(
            "%d\n",m);
                }

                
            return 0;
            }

            久久国产精品99精品国产| 久久精品国产亚洲网站| 欧美日韩精品久久免费| 久久久久久毛片免费看| 精品人妻久久久久久888| 久久国产精品一区二区| 中文成人久久久久影院免费观看| 国产香蕉久久精品综合网| 国产精品无码久久综合| 亚洲一区精品伊人久久伊人| 中文精品久久久久人妻不卡| 国产69精品久久久久99| 亚洲愉拍99热成人精品热久久| 欧美精品一本久久男人的天堂| 国产成人精品久久| 欧美无乱码久久久免费午夜一区二区三区中文字幕 | 久久综合狠狠综合久久| 久久精品国产一区二区电影| 国产精品美女久久久m| 久久丫忘忧草产品| 亚洲精品乱码久久久久久蜜桃 | 无码人妻久久一区二区三区| 精品久久久无码中文字幕天天| 久久精品国产第一区二区三区| 亚洲国产成人久久综合碰| 国产精品久久久久一区二区三区| 久久精品国产久精国产思思| 色综合久久无码五十路人妻| 久久精品卫校国产小美女| 亚洲国产精品成人久久蜜臀| 久久久久久国产a免费观看不卡| 精品久久久久久国产| 国产成人精品久久二区二区| 精品无码久久久久久尤物| 久久精品一本到99热免费| 亚洲色婷婷综合久久| 99蜜桃臀久久久欧美精品网站 | 久久97精品久久久久久久不卡| 久久免费的精品国产V∧| 日韩精品久久久久久免费| 亚洲中文精品久久久久久不卡|