• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>
            posts - 21, comments - 2, trackbacks - 0, articles - 0

            HDU 1087 Super Jumping

            Posted on 2011-10-03 01:28 acpeng 閱讀(291) 評論(0)  編輯 收藏 引用 所屬分類: ACM程序
            題目鏈接:http://acm.hdu.edu.cn/showproblem.php?pid=1087
            Problem Description
            Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.


            The game can be played by two or more than two players. It consists of a chessboard(棋盤)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
            Your task is to output the maximum value according to the given chessmen list.
            Input
            Input contains multiple test cases. Each test case is described in a line as follow:
            N value_1 value_2 …value_N
            It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
            A test case starting with 0 terminates the input and this test case is not to be processed.
            Output
            For each case, print the maximum according to rules, and one line one case.

            Sample Input
            3 1 3 2 4 1 2 3 4 4 3 3 2 1 0
            Sample Output
            4 10 3













            典型的入門級DP題,解題思路:
            定義MaxIncludeEnd數組,令MaxIncludeEnd[i]表示以a[i]結尾的最大和,那么
            MaxIncludeEnd[i]=max{ MaxIncludeEnd[i] , a[j]<a[i] ? (MaxIncludeEnd[j]+a[i]) :-1; }
            其中j=0 to i-1;MaxIncludeEnd[i]的初始值為a[i]。
            #include<stdio.h>
            int a[1003],MaxIncludeEnd[1003];
            int main()
            {
                
            int n,max,i,j;
                
            while(scanf("%d",&n),n)
                
            {
                    
            for(i=0;i<n;i++)
                    
            {
                        scanf(
            "%d",&a[i]);
                        MaxIncludeEnd[i]
            =a[i];
                    }

                    max
            =MaxIncludeEnd[0];
                    
            for(i=0;i<n;i++)
                    
            {
                        
            for(j=0;j<i;j++)
                        
            {
                            
            if(a[j]<a[i] && MaxIncludeEnd[j]+a[i]>MaxIncludeEnd[i])
                                MaxIncludeEnd[i]
            =MaxIncludeEnd[j]+a[i];
                        }

                        
            if(max<MaxIncludeEnd[i])max=MaxIncludeEnd[i];
                    }

                    printf(
            "%d\n",max);
                }

                
            return 0;
            }



            久久久久久毛片免费播放| 模特私拍国产精品久久| 青青草原精品99久久精品66| 麻豆AV一区二区三区久久 | 久久青草国产精品一区| 久久久精品视频免费观看| 亚洲人成网站999久久久综合| 久久久久AV综合网成人| 草草久久久无码国产专区| 久久棈精品久久久久久噜噜| 91精品国产综合久久四虎久久无码一级 | 久久一区二区三区免费| 久久中文娱乐网| 精品国产99久久久久久麻豆| 久久香蕉国产线看观看猫咪?v| 一本色道久久88—综合亚洲精品 | 久久精品水蜜桃av综合天堂| 国内精品伊人久久久久影院对白| 国产高潮国产高潮久久久| 久久亚洲春色中文字幕久久久| 色婷婷狠狠久久综合五月| 少妇久久久久久被弄到高潮| 精品久久香蕉国产线看观看亚洲| 国产成人精品久久一区二区三区| 国产V亚洲V天堂无码久久久| 久久亚洲熟女cc98cm| 一本久久a久久精品亚洲| 一级a性色生活片久久无| 久久高潮一级毛片免费| 国产成人综合久久精品尤物| a级毛片无码兔费真人久久| 日本道色综合久久影院| 久久精品国产精品亚洲精品 | 亚洲精品无码久久久影院相关影片| 欧美日韩精品久久免费| 久久国产成人午夜AV影院| 久久九九亚洲精品| 国产69精品久久久久9999| www亚洲欲色成人久久精品| 国产69精品久久久久9999| 久久久久久久久久久免费精品|