• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            bon

              C++博客 :: 首頁 :: 聯系 :: 聚合  :: 管理
              46 Posts :: 0 Stories :: 12 Comments :: 0 Trackbacks

            常用鏈接

            留言簿(2)

            我參與的團隊

            搜索

            •  

            最新評論

            閱讀排行榜

            評論排行榜

             

            The Perfect Stall
            Time Limit: 1000MS Memory Limit: 10000K
            Total Submissions: 2136 Accepted: 961

            Description

            Farmer John completed his new barn just last week, complete with all the latest milking technology. Unfortunately, due to engineering problems, all the stalls in the new barn are different. For the first week, Farmer John randomly assigned cows to stalls, but it quickly became clear that any given cow was only willing to produce milk in certain stalls. For the last week, Farmer John has been collecting data on which cows are willing to produce milk in which stalls. A stall may be only assigned to one cow, and, of course, a cow may be only assigned to one stall.
            Given the preferences of the cows, compute the maximum number of milk-producing assignments of cows to stalls that is possible.

            Input

            The input includes several cases. For each case, the first line contains two integers, N (0 <= N <= 200) and M (0 <= M <= 200). N is the number of cows that Farmer John has and M is the number of stalls in the new barn. Each of the following N lines corresponds to a single cow. The first integer (Si) on the line is the number of stalls that the cow is willing to produce milk in (0 <= Si <= M). The subsequent Si integers on that line are the stalls in which that cow is willing to produce milk. The stall numbers will be integers in the range (1..M), and no stall will be listed twice for a given cow.

            Output

            For each case, output a single line with a single integer, the maximum number of milk-producing stall assignments that can be made.

            Sample Input

            5 5
            2 2 5
            3 2 3 4
            2 1 5
            3 1 2 5
            1 2
            

             

            Sample Output

            4

            #include <iostream>

            using namespace std;

            int map[201][201];
            int match[201];
            int visit[201];
            int n,m;

            bool dfs(int p)
            {
                
            int x;
                
            for(x=0;x<m;x++)
                
            {
                    
            if(map[p][x]==1 && visit[x]==-1)
                    
            {
                        visit[x]
            =1;
                        
            int t=match[x];
                        match[x]
            =p;
                        
            if(t==-1 || dfs(t)) return true;
                        match[x]
            =t;
                    }

                }

                
            return false;
            }


            int find_match()
            {
                memset(match,
            -1,sizeof(match));
                
            int i,sum=0;
                
            for(i=0;i<n;i++)
                
            {
                    memset(visit,
            -1,sizeof(visit));
                    
            if(dfs(i)) sum++;
                }

                
            return sum;
            }


            int main()
            {
                
            //freopen("in.txt","r",stdin);
                while(scanf("%d%d",&n,&m)!=EOF)
                
            {
                    
            int i,j;
                    
            for(i=0;i<n;i++)
                        
            for(j=0;j<m;j++) map[i][j]=0;
                    
            for(i=0;i<n;i++)
                    
            {
                        
            int a,b;
                        scanf(
            "%d",&a);
                        
            for(j=0;j<a;j++)
                        
            {
                            scanf(
            "%d",&b);
                            map[i][b
            -1]=1;
                        }

                    }

                    
            int res=find_match();
                    printf(
            "%d\n",res);
                }

                
            return 1;
            }
            參考了郭嵩山的第三冊,用網上的代碼似乎有錯。
            posted on 2007-12-31 12:53 bon 閱讀(237) 評論(0)  編輯 收藏 引用
            Google PageRank 
Checker - Page Rank Calculator
            无码任你躁久久久久久老妇App| 精品国产综合区久久久久久| 国产精品久久久久久五月尺| 久久一区二区三区免费| 久久影院亚洲一区| 色婷婷综合久久久久中文一区二区| 久久这里的只有是精品23| 国产精品一区二区久久不卡| 品成人欧美大片久久国产欧美...| 久久久久国产一区二区三区| 性欧美丰满熟妇XXXX性久久久 | 2021久久精品国产99国产精品| 91精品国产综合久久精品| 久久精品亚洲乱码伦伦中文| 久久精品国产2020| 久久国产成人午夜aⅴ影院| 久久婷婷五月综合色奶水99啪| 久久精品国产网红主播| 久久久久亚洲国产| 国产精品久久久久久福利69堂| 久久只有这精品99| 欧美久久久久久午夜精品| 久久精品中文字幕无码绿巨人| 久久精品国产一区二区三区不卡| 亚洲AV日韩精品久久久久久久| 久久这里有精品视频| 精品久久久久久无码国产| 狠狠色丁香久久婷婷综合五月| 亚洲日本va午夜中文字幕久久| 久久线看观看精品香蕉国产| 日韩精品久久久久久久电影蜜臀 | 狠狠色狠狠色综合久久| 久久中文字幕视频、最近更新| 国产精品久久久久AV福利动漫| 久久人人爽人人人人片av| 久久久久综合国产欧美一区二区| 久久96国产精品久久久| 国产精品一久久香蕉国产线看| 久久永久免费人妻精品下载| 久久久久久久久久久久中文字幕 | 中文字幕精品无码久久久久久3D日动漫 |