• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            bon

              C++博客 :: 首頁 :: 聯系 :: 聚合  :: 管理
              46 Posts :: 0 Stories :: 12 Comments :: 0 Trackbacks

            常用鏈接

            留言簿(2)

            我參與的團隊

            搜索

            •  

            最新評論

            閱讀排行榜

            評論排行榜

             

            The Perfect Stall
            Time Limit: 1000MS Memory Limit: 10000K
            Total Submissions: 2136 Accepted: 961

            Description

            Farmer John completed his new barn just last week, complete with all the latest milking technology. Unfortunately, due to engineering problems, all the stalls in the new barn are different. For the first week, Farmer John randomly assigned cows to stalls, but it quickly became clear that any given cow was only willing to produce milk in certain stalls. For the last week, Farmer John has been collecting data on which cows are willing to produce milk in which stalls. A stall may be only assigned to one cow, and, of course, a cow may be only assigned to one stall.
            Given the preferences of the cows, compute the maximum number of milk-producing assignments of cows to stalls that is possible.

            Input

            The input includes several cases. For each case, the first line contains two integers, N (0 <= N <= 200) and M (0 <= M <= 200). N is the number of cows that Farmer John has and M is the number of stalls in the new barn. Each of the following N lines corresponds to a single cow. The first integer (Si) on the line is the number of stalls that the cow is willing to produce milk in (0 <= Si <= M). The subsequent Si integers on that line are the stalls in which that cow is willing to produce milk. The stall numbers will be integers in the range (1..M), and no stall will be listed twice for a given cow.

            Output

            For each case, output a single line with a single integer, the maximum number of milk-producing stall assignments that can be made.

            Sample Input

            5 5
            2 2 5
            3 2 3 4
            2 1 5
            3 1 2 5
            1 2
            

             

            Sample Output

            4

            #include <iostream>

            using namespace std;

            int map[201][201];
            int match[201];
            int visit[201];
            int n,m;

            bool dfs(int p)
            {
                
            int x;
                
            for(x=0;x<m;x++)
                
            {
                    
            if(map[p][x]==1 && visit[x]==-1)
                    
            {
                        visit[x]
            =1;
                        
            int t=match[x];
                        match[x]
            =p;
                        
            if(t==-1 || dfs(t)) return true;
                        match[x]
            =t;
                    }

                }

                
            return false;
            }


            int find_match()
            {
                memset(match,
            -1,sizeof(match));
                
            int i,sum=0;
                
            for(i=0;i<n;i++)
                
            {
                    memset(visit,
            -1,sizeof(visit));
                    
            if(dfs(i)) sum++;
                }

                
            return sum;
            }


            int main()
            {
                
            //freopen("in.txt","r",stdin);
                while(scanf("%d%d",&n,&m)!=EOF)
                
            {
                    
            int i,j;
                    
            for(i=0;i<n;i++)
                        
            for(j=0;j<m;j++) map[i][j]=0;
                    
            for(i=0;i<n;i++)
                    
            {
                        
            int a,b;
                        scanf(
            "%d",&a);
                        
            for(j=0;j<a;j++)
                        
            {
                            scanf(
            "%d",&b);
                            map[i][b
            -1]=1;
                        }

                    }

                    
            int res=find_match();
                    printf(
            "%d\n",res);
                }

                
            return 1;
            }
            參考了郭嵩山的第三冊,用網上的代碼似乎有錯。
            posted on 2007-12-31 12:53 bon 閱讀(237) 評論(0)  編輯 收藏 引用
            Google PageRank 
Checker - Page Rank Calculator
            久久精品一本到99热免费| 精品久久久久久无码不卡| 久久精品国产亚洲av日韩| 久久精品欧美日韩精品| 久久综合久久综合久久综合| 91精品国产91久久久久久| 久久影院亚洲一区| 国内精品久久久久久99蜜桃 | 国产亚州精品女人久久久久久| 久久人人爽人爽人人爽av| 国内精品人妻无码久久久影院导航| 国产99精品久久| 伊人久久精品影院| 久久精品国产亚洲欧美| 精品人妻伦九区久久AAA片69| 狠狠久久综合伊人不卡| 久久久一本精品99久久精品66| 日韩影院久久| 人人狠狠综合久久亚洲婷婷| 久久精品国产99久久无毒不卡 | 久久综合成人网| 久久er国产精品免费观看2| 国产A级毛片久久久精品毛片| 色综合久久天天综合| 久久久久国产精品熟女影院 | 最新久久免费视频| 国产成人综合久久久久久| 久久久久人妻一区精品性色av| 久久人人爽人人澡人人高潮AV| 天天爽天天爽天天片a久久网| 国产精品99久久免费观看| 久久久久久久久久久久中文字幕| 久久久久久国产精品无码下载| 热99RE久久精品这里都是精品免费 | 久久成人18免费网站| 国产99久久久久久免费看 | 伊人久久大香线蕉综合热线| 久久精品国产精品亜洲毛片 | 久久96国产精品久久久| 久久久久亚洲AV无码网站| 精品久久久无码人妻中文字幕豆芽 |