• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>
            Welcome to Leon's Blog  
            日歷
            <2008年5月>
            27282930123
            45678910
            11121314151617
            18192021222324
            25262728293031
            1234567
            統計
            • 隨筆 - 30
            • 文章 - 0
            • 評論 - 51
            • 引用 - 0

            導航

            常用鏈接

            留言簿(4)

            隨筆分類

            隨筆檔案

            ACM

            搜索

            •  

            最新評論

            閱讀排行榜

            評論排行榜

             
                 今天做完1006題,第一次用枚舉法,但是時間復雜度大,后來看到帖子說是用中國余數法。自己試著也寫了一個,但是用時也過大,現在把代碼貼出來,請大家幫忙改一改啊!謝謝了!
             1#include <stdio.h>
             2
             3int main(int argc, char* argv[])
             4{
             5    int p,e,i,d, index;
             6    int day;
             7    int x = 28*33*6;
             8    int y = 23*33*19;
             9    int z = 23*28*2;
            10    index = 0;
            11    
            12
            13    do
            14    {
            15        scanf("%d %d %d %d"&p,&e, &i, &d);
            16        if(p == -1 && e == -1 && i == -1 && d == -1)
            17            break;
            18        p = p%23;
            19        e = e%28;
            20        i = i%33;
            21        day = (p*+ e*+ i*z) % 21252;
            22        if(day == d)
            23            day += 21252;
            24        printf("Case %d: the next triple peak occurs in %d days.\n"++index,day->= 0 ? day-d : day-d+21252);
            25    }
            while(1); 
            26    return 0;
            27}
            posted on 2008-05-30 20:43 Leon916 閱讀(1222) 評論(4)  編輯 收藏 引用
            評論:
            • # re: 1006求助  夜弓 Posted @ 2008-05-31 07:21
              /*
              Description
              Some people believe that there are three cycles in a person's life that start the day he or she is born. These three cycles are the physical, emotional, and intellectual cycles, and they have periods of lengths 23, 28, and 33 days, respectively. There is one peak in each period of a cycle. At the peak of a cycle, a person performs at his or her best in the corresponding field (physical, emotional or mental). For example, if it is the mental curve, thought processes will be sharper and concentration will be easier.
              Since the three cycles have different periods, the peaks of the three cycles generally occur at different times. We would like to determine when a triple peak occurs (the peaks of all three cycles occur in the same day) for any person. For each cycle, you will be given the number of days from the beginning of the current year at which one of its peaks (not necessarily the first) occurs. You will also be given a date expressed as the number of days from the beginning of the current year. You task is to determine the number of days from the given date to the next triple peak. The given date is not counted. For example, if the given date is 10 and the next triple peak occurs on day 12, the answer is 2, not 3. If a triple peak occurs on the given date, you should give the number of days to the next occurrence of a triple peak.

              Input
              You will be given a number of cases. The input for each case consists of one line of four integers p, e, i, and d. The values p, e, and i are the number of days from the beginning of the current year at which the physical, emotional, and intellectual cycles peak, respectively. The value d is the given date and may be smaller than any of p, e, or i. All values are non-negative and at most 365, and you may assume that a triple peak will occur within 21252 days of the given date. The end of input is indicated by a line in which p = e = i = d = -1.

              Output
              For each test case, print the case number followed by a message indicating the number of days to the next triple peak, in the form:

              Case 1: the next triple peak occurs in 1234 days.

              Use the plural form ``days'' even if the answer is 1.

              Sample Input

              0 0 0 0
              0 0 0 100
              5 20 34 325
              4 5 6 7
              283 102 23 320
              203 301 203 40
              -1 -1 -1 -1

              Sample Output

              Case 1: the next triple peak occurs in 21252 days.
              Case 2: the next triple peak occurs in 21152 days.
              Case 3: the next triple peak occurs in 19575 days.
              Case 4: the next triple peak occurs in 16994 days.
              Case 5: the next triple peak occurs in 8910 days.
              Case 6: the next triple peak occurs in 10789 days.*/
              #include <cstdio>

              int main()
              {
              int x,y,z,s,t;
              size_t i(0);
              scanf("%d %d %d %d", &x, &y, &z, &s);
              while(x!=-1 || y!=-1 || z!=-1 || s!=-1){
              t = (5544*x + 14421*y + 1288*z) % 21252;
              t -= s;
              if(t<=0)
              t+=21252;
              printf("Case %d: the next triple peak occurs in %d days.\n",
              ++i,t);
              scanf("%d %d %d %d", &x, &y, &z, &s);
              }
              }
                回復  更多評論   

            • # re: 1006求助  夜弓 Posted @ 2008-05-31 07:31
              感覺沒多大區別,我的比你少取了點模
              40K 75MS
              至于哪些超快的,我覺得可能是這個原因:
              那句printf應該改成sprintf,先到緩沖區,最后再輸出~
              不過就算這樣能提高成績,我覺得其實意義也不大~  回復  更多評論   

            • # re: 1006求助  郴州SEO Posted @ 2008-06-01 07:34
              有點暈...  回復  更多評論   

            • # re: 1006求助  Leon916 Posted @ 2008-06-01 11:34
              哦,我在網上看到,有些人寫的程序時間和空間都很少,真不知道是怎么寫出來的  回復  更多評論   

             
            Copyright © Leon916 Powered by: 博客園 模板提供:滬江博客
            日韩欧美亚洲综合久久影院Ds| 国产精品久久久久国产A级| 久久中文精品无码中文字幕| 午夜精品久久久久久| 精品国产乱码久久久久软件 | 99久久99这里只有免费费精品 | 亚洲国产成人精品女人久久久| 色诱久久av| 久久精品国产一区| 久久青青草视频| 91精品无码久久久久久五月天| 九九精品久久久久久噜噜| 国内精品久久久久影院日本| 亚洲午夜福利精品久久| 久久久精品一区二区三区| 久久AV无码精品人妻糸列| 精品人妻伦九区久久AAA片69| 亚洲精品高清国产一线久久| 久久久WWW成人免费毛片| 久久久精品国产sm调教网站 | 久久精品aⅴ无码中文字字幕不卡 久久精品成人欧美大片 | 日本福利片国产午夜久久| 久久SE精品一区二区| 伊人久久大香线蕉无码麻豆| 久久人人爽人人爽人人片AV高清| 色综合久久88色综合天天| 性高朝久久久久久久久久| 色综合久久综精品| 久久精品这里只有精99品| 久久精品国产亚洲AV无码娇色| 亚洲日本va午夜中文字幕久久 | 一本久久久久久久| 国产精品免费看久久久| 色婷婷综合久久久中文字幕| 亚洲Av无码国产情品久久| 人妻少妇精品久久| 亚洲中文字幕伊人久久无码| 久久亚洲精品无码VA大香大香| 无码任你躁久久久久久久| 久久无码国产专区精品| 久久亚洲精品无码VA大香大香|