• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            ArcTan

            dfs
            隨筆 - 16, 文章 - 117, 評論 - 6, 引用 - 0
            數據加載中……

            白書上的動態規劃D---dp組合計數問題

            Coin Change 

            Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.


            For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, two 5-cent coins and one 1-cent coin, one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents with the above coins. Note that we count that there is one way of making change for zero cent.


            Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 7489 cents.

            Input 

            The input file contains any number of lines, each one consisting of a number for the amount of money in cents.

            Output 

            For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.

            Sample Input 

            11 26 

            Sample Output 

            4 13 

            題目大意:

             給定1 5 10 25 50五種硬幣,給定一個數,問用這些硬幣有多少種不同的組合方式?

            想想好像可以是一個方程組求解的問題嘛:

                            x1+5*x2+10*x3+25*x4+50*x5=x0;

                            給定x0,一組滿足條件的x>=0就是解集。啊哈哈哈。可以高斯消元法咯。

            不過,明顯的計數問題:

            dp[i][j]表示i可以由前j種硬幣表示的方法數。

            dp[i][j]=dp[i][j-1]+dp[i-coin[j]][j]     i-coin[j]>0

            dp[i][j]=dp[i][j-1]+1  i-coin[j]=0;

            dp[i][j]=dp[i][j-1] i-coin[j]<0

            總結:

                  方程類問題,一定要先把方程寫清楚!!!

            #include<stdio.h>
            #include<string.h>
            #include<math.h>
            long long dp
            [7500][5],coin[5]={1,5,10,25,50};
            int GetAns()
            {
                int i
            ,j;
                memset(dp,0,sizeof(dp));
                dp[1][0]=dp[1][1]=dp[1][2]=dp[1][3]=dp[1][4]=1;
                for (i=2;i<=7489 ;i++ )
                {
                    dp
            [i][0]=1;
                    for (j=1;j<5 ;j++ )
                        if (i-coin[j]>0)
                            dp
            [i][j]=dp[i][j-1]+dp[i-coin[j]][j];
                        else
                            if (i-coin
            [j]==0)
                                dp
            [i][j]=dp[i][j-1]+1;
                            else
                                dp
            [i][j]=dp[i][j-1];
                }
            }
            int main()
            {
                int n
            ;
                GetAns();
                while (scanf("%d",&n)==1)
                    printf(
            "%lld\n",dp[n][4]);
                return 0;
            }


            額額,dp是個好東西,該看看優化了!!!

            posted on 2012-04-29 19:11 wangs 閱讀(846) 評論(0)  編輯 收藏 引用 所屬分類: ACM-DP

            久久久久久国产精品无码超碰| 精品久久久久久久无码| 狠狠色丁香久久婷婷综合五月| 亚洲v国产v天堂a无码久久| 亚洲一本综合久久| 伊人久久免费视频| 日本道色综合久久影院| 色综合久久综精品| 曰曰摸天天摸人人看久久久| 免费观看成人久久网免费观看| 久久精品国产亚洲AV电影| 东京热TOKYO综合久久精品| 高清免费久久午夜精品| 亚洲国产成人久久综合一| 久久国产视屏| 久久人人爽人人爽人人av东京热| 久久午夜福利无码1000合集| 亚洲国产美女精品久久久久∴| 韩国免费A级毛片久久| 日本久久久久久中文字幕| 久久一区二区三区免费| 狠狠综合久久AV一区二区三区 | 久久久精品一区二区三区| 亚洲综合精品香蕉久久网97 | 亚洲人成电影网站久久| 精品熟女少妇AV免费久久| 久久99精品国产自在现线小黄鸭| 久久精品国产91久久综合麻豆自制| 国产高潮国产高潮久久久91 | 热re99久久精品国产99热| 久久精品国产72国产精福利| 国产99久久久国产精品小说| 97久久精品无码一区二区| 精品多毛少妇人妻AV免费久久| 久久久久亚洲精品日久生情 | 久久精品亚洲AV久久久无码| 久久亚洲中文字幕精品有坂深雪 | 丰满少妇高潮惨叫久久久| 欧美久久久久久午夜精品| 久久精品蜜芽亚洲国产AV| 香蕉99久久国产综合精品宅男自|