• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            ArcTan

            dfs
            隨筆 - 16, 文章 - 117, 評論 - 6, 引用 - 0
            數(shù)據(jù)加載中……

            白書上的動態(tài)規(guī)劃D---dp組合計(jì)數(shù)問題

            Coin Change 

            Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.


            For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, two 5-cent coins and one 1-cent coin, one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents with the above coins. Note that we count that there is one way of making change for zero cent.


            Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 7489 cents.

            Input 

            The input file contains any number of lines, each one consisting of a number for the amount of money in cents.

            Output 

            For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.

            Sample Input 

            11 26 

            Sample Output 

            4 13 

            題目大意:

             給定1 5 10 25 50五種硬幣,給定一個數(shù),問用這些硬幣有多少種不同的組合方式?

            想想好像可以是一個方程組求解的問題嘛:

                            x1+5*x2+10*x3+25*x4+50*x5=x0;

                            給定x0,一組滿足條件的x>=0就是解集。啊哈哈哈。可以高斯消元法咯。

            不過,明顯的計(jì)數(shù)問題:

            dp[i][j]表示i可以由前j種硬幣表示的方法數(shù)。

            dp[i][j]=dp[i][j-1]+dp[i-coin[j]][j]     i-coin[j]>0

            dp[i][j]=dp[i][j-1]+1  i-coin[j]=0;

            dp[i][j]=dp[i][j-1] i-coin[j]<0

            總結(jié):

                  方程類問題,一定要先把方程寫清楚!!!

            #include<stdio.h>
            #include<string.h>
            #include<math.h>
            long long dp
            [7500][5],coin[5]={1,5,10,25,50};
            int GetAns()
            {
                int i
            ,j;
                memset(dp,0,sizeof(dp));
                dp[1][0]=dp[1][1]=dp[1][2]=dp[1][3]=dp[1][4]=1;
                for (i=2;i<=7489 ;i++ )
                {
                    dp
            [i][0]=1;
                    for (j=1;j<5 ;j++ )
                        if (i-coin[j]>0)
                            dp
            [i][j]=dp[i][j-1]+dp[i-coin[j]][j];
                        else
                            if (i-coin
            [j]==0)
                                dp
            [i][j]=dp[i][j-1]+1;
                            else
                                dp
            [i][j]=dp[i][j-1];
                }
            }
            int main()
            {
                int n
            ;
                GetAns();
                while (scanf("%d",&n)==1)
                    printf(
            "%lld\n",dp[n][4]);
                return 0;
            }


            額額,dp是個好東西,該看看優(yōu)化了!!!

            posted on 2012-04-29 19:11 wangs 閱讀(846) 評論(0)  編輯 收藏 引用 所屬分類: ACM-DP

            久久亚洲私人国产精品vA| 久久人人爽人人澡人人高潮AV | 久久亚洲私人国产精品vA| 亚洲国产精品无码久久SM| 浪潮AV色综合久久天堂| 国产精品综合久久第一页 | 国内精品人妻无码久久久影院 | 亚洲乱码精品久久久久..| 久久人人爽人人爽人人AV| 中文字幕亚洲综合久久| 偷偷做久久久久网站| 久久久久四虎国产精品| 久久国语露脸国产精品电影| 久久99精品国产99久久6男男| 精品视频久久久久| 久久久女人与动物群交毛片 | 国产精品一区二区久久精品无码| 久久嫩草影院免费看夜色| 久久精品国产精品国产精品污| 久久综合久久鬼色| 国产99精品久久| 无码国内精品久久人妻蜜桃 | 区亚洲欧美一级久久精品亚洲精品成人网久久久久| 国产精品永久久久久久久久久| 久久亚洲国产成人精品性色| 手机看片久久高清国产日韩| 国内精品久久人妻互换| 久久久久亚洲AV片无码下载蜜桃| 伊人久久大香线焦综合四虎 | 精品久久久久国产免费| 国产精品美女久久久久网| 精品国产乱码久久久久久呢| 天堂无码久久综合东京热| 久久久久综合国产欧美一区二区| 色综合久久中文综合网| 久久青草国产精品一区| 7777精品伊人久久久大香线蕉| 久久精品夜色噜噜亚洲A∨| 一级做a爱片久久毛片| 91精品久久久久久无码| 九九久久精品国产|