• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            ArcTan

            dfs
            隨筆 - 16, 文章 - 117, 評論 - 6, 引用 - 0
            數(shù)據(jù)加載中……

            白書上的動態(tài)規(guī)劃D---dp組合計數(shù)問題

            Coin Change 

            Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.


            For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, two 5-cent coins and one 1-cent coin, one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents with the above coins. Note that we count that there is one way of making change for zero cent.


            Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 7489 cents.

            Input 

            The input file contains any number of lines, each one consisting of a number for the amount of money in cents.

            Output 

            For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.

            Sample Input 

            11 26 

            Sample Output 

            4 13 

            題目大意:

             給定1 5 10 25 50五種硬幣,給定一個數(shù),問用這些硬幣有多少種不同的組合方式?

            想想好像可以是一個方程組求解的問題嘛:

                            x1+5*x2+10*x3+25*x4+50*x5=x0;

                            給定x0,一組滿足條件的x>=0就是解集。啊哈哈哈。可以高斯消元法咯。

            不過,明顯的計數(shù)問題:

            dp[i][j]表示i可以由前j種硬幣表示的方法數(shù)。

            dp[i][j]=dp[i][j-1]+dp[i-coin[j]][j]     i-coin[j]>0

            dp[i][j]=dp[i][j-1]+1  i-coin[j]=0;

            dp[i][j]=dp[i][j-1] i-coin[j]<0

            總結(jié):

                  方程類問題,一定要先把方程寫清楚!!!

            #include<stdio.h>
            #include<string.h>
            #include<math.h>
            long long dp
            [7500][5],coin[5]={1,5,10,25,50};
            int GetAns()
            {
                int i
            ,j;
                memset(dp,0,sizeof(dp));
                dp[1][0]=dp[1][1]=dp[1][2]=dp[1][3]=dp[1][4]=1;
                for (i=2;i<=7489 ;i++ )
                {
                    dp
            [i][0]=1;
                    for (j=1;j<5 ;j++ )
                        if (i-coin[j]>0)
                            dp
            [i][j]=dp[i][j-1]+dp[i-coin[j]][j];
                        else
                            if (i-coin
            [j]==0)
                                dp
            [i][j]=dp[i][j-1]+1;
                            else
                                dp
            [i][j]=dp[i][j-1];
                }
            }
            int main()
            {
                int n
            ;
                GetAns();
                while (scanf("%d",&n)==1)
                    printf(
            "%lld\n",dp[n][4]);
                return 0;
            }


            額額,dp是個好東西,該看看優(yōu)化了!!!

            posted on 2012-04-29 19:11 wangs 閱讀(269) 評論(0)  編輯 收藏 引用 所屬分類: ACM-DP

            久久精品成人免费国产片小草| 久久免费小视频| 久久影视国产亚洲| 青青草原精品99久久精品66| 亚洲狠狠综合久久| 中文字幕无码精品亚洲资源网久久| 精品国产乱码久久久久久1区2区 | 伊人色综合久久| 亚洲人成网站999久久久综合| 久久久精品2019免费观看| 欧美精品福利视频一区二区三区久久久精品| 久久青青草原亚洲av无码| 久久久久亚洲av无码专区| 久久久人妻精品无码一区| 国产精品久久久久久吹潮| 四虎国产精品免费久久| 国产精品欧美久久久久无广告| 精品久久久噜噜噜久久久| 久久亚洲精品无码播放| 精品一区二区久久| 国产精品成人久久久久三级午夜电影 | 久久人人爽人人精品视频| WWW婷婷AV久久久影片| 99精品国产免费久久久久久下载| 久久一区二区三区免费| 久久综合中文字幕| 精品熟女少妇a∨免费久久| 久久天天躁夜夜躁狠狠| 人妻少妇久久中文字幕一区二区| 久久久久亚洲?V成人无码| 国产精品xxxx国产喷水亚洲国产精品无码久久一区 | 色综合久久综精品| 99国产精品久久| 办公室久久精品| 久久精品国产一区| 久久精品国产精品亚洲精品| 久久99国产综合精品免费| 国产V综合V亚洲欧美久久| 久久久久久久久久久久中文字幕| 亚洲人成精品久久久久| 色妞色综合久久夜夜|