• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            ZOJ 1032 Area 2

            Area 2

            Time limit: 1 Seconds   Memory limit: 32768K  
            Total Submit: 735   Accepted Submit: 317  

            Background

            Being well known for its highly innovative products, Merck would definitely be a good target for industrial espionage. To protect its brand-new research and development facility the company has installed the latest system of surveillance robots patrolling the area. These robots move along the walls of the facility and report suspicious observations to the central security office. The only flaw in the system a competitor’s agent could find is the fact that the robots radio their movements unencrypted. Not being able to find out more, the agent wants to use that information to calculate the exact size of the area occupied by the new facility. It is public knowledge that all the corners of the building are situated on a rectangular grid and that only straight walls are used. Figure 1 shows the course of a robot around an example area.

            Figure 1: Example area.

            Problem

            You are hired to write a program that calculates the area occupied by the new facility from the movements of a robot along its walls. You can assume that this area is a polygon with corners on a rectangular grid. However, your boss insists that you use a formula he is so proud to have found somewhere. The formula relates the number I of grid points inside the polygon, the number E of grid points on the edges, and the total area A of the polygon. Unfortunately, you have lost the sheet on which he had written down that simple formula for you, so your first task is to find the formula yourself.


            Input

            The first line contains the number of scenarios.

            For each scenario, you are given the number m, 3<=m<100, of movements of the robot in the first line. The following m lines contain pairs “dx dy” of integers, separated by a single blank, satisfying .-100<=dx, dy<=100 and (dx, dy)!=(0, 0). Such a pair means that the robot moves on to a grid point dx units to the right and dy units upwards on the grid (with respect to the current position). You can assume that the curve along which the robot moves is closed and that it does not intersect or even touch itself except for the start and end points. The robot moves anti-clockwise around the building, so the area to be calculated lies to the left of the curve. It is known in advance that the whole polygon would fit into a square on the grid with a side length of 100 units.


            Output

            The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line containing I, E, and A, the area A rounded to one digit after the decimal point. Separate the three numbers by two single blanks. Terminate the output for the scenario with a blank line.


            Sample Input

            2
            4
            1 0
            0 1
            -1 0
            0 -1
            7
            5 0
            1 3
            -2 2
            -1 0
            0 -3
            -3 1
            0 -3


            Sample Output

            Scenario #1:
            0 4 1.0

            Scenario #2:
            12 16 19.0


            Problem Source: Northwestern Europe 2001

             Analysis
            Algorithm:
            It is a basic computational geometry problem. For the task, the description aims us to calculate the points inner and on edge. But we can measure the area by the vector formular:
            (P.S: the n+1 point is actually the first one,so  .)
            Later, using the pick formulat to calculate the inner points, while the points on the edge can be counted with the move vector, which is proved to be as same as the number of  .

            Code:
            #include <iostream>
            using namespace std;
            struct delta{
                
            int dx;
                
            int dy;
            }
            ;
            delta move[
            101];

            int gcd(int a,int b){
                
            if (a==0return b;
                
            if (b==0return a;
                
            return gcd(b,a%b);
            }

            int abs(int a){
                
            return a>0?a:-1*a;
            }

            int main(){
                
            int Scenario,s;
                cin
            >>s;
                
            for (Scenario=1;Scenario<=s;Scenario++){
                    
            int I=0,E=0,area=0;
                    
            int m;
                    cin
            >>m;
                    move[
            0].dx=0;
                    move[
            0].dy=0;
                    
            for (int i=1;i<=m;i++){
                        cin
            >>move[i].dx>>move[i].dy;
                        E
            +=gcd(abs(move[i].dx),abs(move[i].dy));
                        move[i].dx
            +=move[i-1].dx;
                        move[i].dy
            +=move[i-1].dy;
                    }

                    
            for (i=1;i<m-1;i++){
                        area
            +=move[i].dx*move[i+1].dy-move[i].dy*move[i+1].dx;
                    }

                    area
            =abs(area);
                    I
            =(area+2-E)/2;
                    cout
            <<"Scenario #"<<Scenario<<":"<<endl;
                    cout
            <<I<<" "<<E<<" ";
                    
            if (area%2) cout<<area/2+0.5<<endl;
                    
            else cout<<area/2<<".0"<<endl;
                    cout 
            <<endl;
                    
            for (i=1;i<=m;i++){
                        move[i].dx
            =0;
                        move[i].dy
            =0;
                    }

                }

                
            return 0;
            }

            posted on 2008-08-09 19:02 幻浪天空領(lǐng)主 閱讀(507) 評(píng)論(0)  編輯 收藏 引用 所屬分類: ZOJ

            <2025年5月>
            27282930123
            45678910
            11121314151617
            18192021222324
            25262728293031
            1234567

            導(dǎo)航

            統(tǒng)計(jì)

            常用鏈接

            留言簿(1)

            隨筆檔案(2)

            文章分類(23)

            文章檔案(22)

            搜索

            最新評(píng)論

            閱讀排行榜

            評(píng)論排行榜

            久久久久久国产a免费观看不卡| 国内精品久久久久影院一蜜桃| 久久97久久97精品免视看| 久久99精品综合国产首页| 久久精品亚洲男人的天堂| 亚洲欧美国产精品专区久久| 2019久久久高清456| 久久超碰97人人做人人爱| 欧美久久综合性欧美| 亚洲精品WWW久久久久久| 久久亚洲私人国产精品| 久久久久久av无码免费看大片| 久久九九精品99国产精品| 久久夜色撩人精品国产| 国产∨亚洲V天堂无码久久久| 亚洲国产精品综合久久网络 | 久久99精品国产自在现线小黄鸭 | 久久久久亚洲AV成人网人人网站| 亚洲AV无码久久精品色欲| 久久99精品免费一区二区| 久久精品国产亚洲AV不卡| 91久久精品国产91性色也| 精品久久久无码人妻中文字幕豆芽| 久久精品国产亚洲一区二区三区| 亚洲国产精品一区二区久久hs| 国产—久久香蕉国产线看观看| 亚洲精品乱码久久久久66| 狠狠色丁香久久婷婷综合_中 | 狠狠色丁香久久婷婷综合_中 | 精品久久久久一区二区三区| 久久精品天天中文字幕人妻| 国产精品久久新婚兰兰| 久久夜色精品国产| 一本色道久久88综合日韩精品| 国产三级观看久久| 国产精品狼人久久久久影院| 91性高湖久久久久| 久久av免费天堂小草播放| 久久精品18| 色诱久久av| 久久夜色精品国产噜噜麻豆|