• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            ZOJ 1032 Area 2

            Area 2

            Time limit: 1 Seconds   Memory limit: 32768K  
            Total Submit: 735   Accepted Submit: 317  

            Background

            Being well known for its highly innovative products, Merck would definitely be a good target for industrial espionage. To protect its brand-new research and development facility the company has installed the latest system of surveillance robots patrolling the area. These robots move along the walls of the facility and report suspicious observations to the central security office. The only flaw in the system a competitor’s agent could find is the fact that the robots radio their movements unencrypted. Not being able to find out more, the agent wants to use that information to calculate the exact size of the area occupied by the new facility. It is public knowledge that all the corners of the building are situated on a rectangular grid and that only straight walls are used. Figure 1 shows the course of a robot around an example area.

            Figure 1: Example area.

            Problem

            You are hired to write a program that calculates the area occupied by the new facility from the movements of a robot along its walls. You can assume that this area is a polygon with corners on a rectangular grid. However, your boss insists that you use a formula he is so proud to have found somewhere. The formula relates the number I of grid points inside the polygon, the number E of grid points on the edges, and the total area A of the polygon. Unfortunately, you have lost the sheet on which he had written down that simple formula for you, so your first task is to find the formula yourself.


            Input

            The first line contains the number of scenarios.

            For each scenario, you are given the number m, 3<=m<100, of movements of the robot in the first line. The following m lines contain pairs “dx dy” of integers, separated by a single blank, satisfying .-100<=dx, dy<=100 and (dx, dy)!=(0, 0). Such a pair means that the robot moves on to a grid point dx units to the right and dy units upwards on the grid (with respect to the current position). You can assume that the curve along which the robot moves is closed and that it does not intersect or even touch itself except for the start and end points. The robot moves anti-clockwise around the building, so the area to be calculated lies to the left of the curve. It is known in advance that the whole polygon would fit into a square on the grid with a side length of 100 units.


            Output

            The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line containing I, E, and A, the area A rounded to one digit after the decimal point. Separate the three numbers by two single blanks. Terminate the output for the scenario with a blank line.


            Sample Input

            2
            4
            1 0
            0 1
            -1 0
            0 -1
            7
            5 0
            1 3
            -2 2
            -1 0
            0 -3
            -3 1
            0 -3


            Sample Output

            Scenario #1:
            0 4 1.0

            Scenario #2:
            12 16 19.0


            Problem Source: Northwestern Europe 2001

             Analysis
            Algorithm:
            It is a basic computational geometry problem. For the task, the description aims us to calculate the points inner and on edge. But we can measure the area by the vector formular:
            (P.S: the n+1 point is actually the first one,so  .)
            Later, using the pick formulat to calculate the inner points, while the points on the edge can be counted with the move vector, which is proved to be as same as the number of  .

            Code:
            #include <iostream>
            using namespace std;
            struct delta{
                
            int dx;
                
            int dy;
            }
            ;
            delta move[
            101];

            int gcd(int a,int b){
                
            if (a==0return b;
                
            if (b==0return a;
                
            return gcd(b,a%b);
            }

            int abs(int a){
                
            return a>0?a:-1*a;
            }

            int main(){
                
            int Scenario,s;
                cin
            >>s;
                
            for (Scenario=1;Scenario<=s;Scenario++){
                    
            int I=0,E=0,area=0;
                    
            int m;
                    cin
            >>m;
                    move[
            0].dx=0;
                    move[
            0].dy=0;
                    
            for (int i=1;i<=m;i++){
                        cin
            >>move[i].dx>>move[i].dy;
                        E
            +=gcd(abs(move[i].dx),abs(move[i].dy));
                        move[i].dx
            +=move[i-1].dx;
                        move[i].dy
            +=move[i-1].dy;
                    }

                    
            for (i=1;i<m-1;i++){
                        area
            +=move[i].dx*move[i+1].dy-move[i].dy*move[i+1].dx;
                    }

                    area
            =abs(area);
                    I
            =(area+2-E)/2;
                    cout
            <<"Scenario #"<<Scenario<<":"<<endl;
                    cout
            <<I<<" "<<E<<" ";
                    
            if (area%2) cout<<area/2+0.5<<endl;
                    
            else cout<<area/2<<".0"<<endl;
                    cout 
            <<endl;
                    
            for (i=1;i<=m;i++){
                        move[i].dx
            =0;
                        move[i].dy
            =0;
                    }

                }

                
            return 0;
            }

            posted on 2008-08-09 19:02 幻浪天空領主 閱讀(507) 評論(0)  編輯 收藏 引用 所屬分類: ZOJ

            <2025年5月>
            27282930123
            45678910
            11121314151617
            18192021222324
            25262728293031
            1234567

            導航

            統計

            常用鏈接

            留言簿(1)

            隨筆檔案(2)

            文章分類(23)

            文章檔案(22)

            搜索

            最新評論

            閱讀排行榜

            評論排行榜

            亚洲中文字幕久久精品无码APP| 国产精品成人精品久久久| 要久久爱在线免费观看| 久久只这里是精品66| 性高湖久久久久久久久| 久久99国产精品久久久| 午夜精品久久久久久| 久久狠狠爱亚洲综合影院| 九九久久99综合一区二区| 久久久精品国产亚洲成人满18免费网站 | 日产精品久久久一区二区| 欧美精品一区二区精品久久| 亚洲精品美女久久久久99小说 | 国产偷久久久精品专区| 99久久精品国产一区二区蜜芽| 国产精品久久久久久久人人看| 久久久国产精品福利免费| 久久精品人人做人人爽电影| 99久久精品免费看国产免费| 麻豆亚洲AV永久无码精品久久| 久久婷婷色综合一区二区| 久久66热人妻偷产精品9| 99久久香蕉国产线看观香| 久久精品国产亚洲麻豆| 亚洲精品乱码久久久久久久久久久久| 国产高清美女一级a毛片久久w | 国产福利电影一区二区三区久久老子无码午夜伦不 | 一级A毛片免费观看久久精品| 91精品久久久久久无码| 精品综合久久久久久888蜜芽| 久久人妻AV中文字幕| 一本色道久久88综合日韩精品 | 久久se精品一区精品二区| 一本一道久久综合狠狠老| 色婷婷狠狠久久综合五月| 久久夜色精品国产| 91精品无码久久久久久五月天| .精品久久久麻豆国产精品| 嫩草伊人久久精品少妇AV| 欧美丰满熟妇BBB久久久| 日日躁夜夜躁狠狠久久AV|