• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>
            posts - 195,  comments - 30,  trackbacks - 0
            2152: A Special Sorting
            Status In/Out TIME Limit MEMORY Limit Submit Times Solved Users JUDGE TYPE
            stdin/stdout 3s 8192K 356 152 Standard

            Give you a sequence of words, can you sort them in dictionary order?

            eg.

            yes
            accidental
            baby
            accept
            accident
            
            In dictionary order, those words should be printed as the following
            accept
            accident
            accidental
            baby
            yes
            
            But we will make an interesting rule this time. See your keyboard or the picture below:

            there are ONLY 26 letters in lower-case we will use, and we assume that the letter above is bigger than the letter below, and the left is bigger than the right. For example, 'q' is bigger than 'a', 'c' is bigger than 'v'. So the example at the beginning whill be...

            Input and Output

            the input will only contain a sequence of words which is less than 1500. the output should print the sorted words each in a single line.

            Sample Input

            yes
            accidental
            baby
            accept
            accident
            

            Sample Output

            baby
            accident
            accidental
            accept
            yes
            

            水題啊!
            #include<iostream>
            #include<cstdlib>
            #include<string>
            #include<algorithm>
            using namespace std;
            int Map[27];
            struct M{
             char s[30];
            }S[1500];
            char table[26]={'q','w','e','r','t','y','u','i','o','p','a','s','d',
            'f','g','h','j','k','l','z','x','c','v','b','n','m'};
            bool operator<(M a,M b)
            {
             int i=strlen(a.s);
             int j=strlen(b.s);
             if(i<j)
             j=i;
             for(int k=0;k<j;k++)
             {
              if(Map[(a.s[k])-'a']<Map[(b.s)[k]-'a'])
              return false;
              if(Map[(a.s[k])-'a']>Map[(b.s)[k]-'a'])
              return true;
             }
             return i==j;//Èç¹ûabcd,abc,abcd<abc
            }
            void search(char key)
            {
             int i;
            for(i=0;i<26;i++)
            {
             if(key==table[i])
             {
              Map[key-'a']=i;
              break;
             }
            }
            }
              int main()
              {
              freopen("s.txt","r",stdin);  
              freopen("key.txt","w",stdout);
              int i;
              string t;
              memset(S,0,sizeof(S));
              for(i=0;i<26;i++)
              {
              search('a'+i);
              }
              i=0;
              while(!cin.eof())
               { 
             cin.getline(S[i++].s,30);//不能用cin>>s;否則runtime  error
               }
             sort(S,S+i-1);
             for(int j=0;j<i-1;j++)//必須用i-1,最后還有個空行。
             cout<<S[j].s<<endl;
              //system("PAUSE");
              return   0;
              }
            奇怪的是在vc上能用
            string s ;
            while(cin>>s)
            {};
            在dev c++ 上不行。
            后來才發現可以
            string s ;
            while(cin>>s)
            {};
            但是不能加 memset(S,0,sizeof(S));
            posted on 2009-07-18 16:11 luis 閱讀(655) 評論(0)  編輯 收藏 引用 所屬分類: 格式.輸入輸出.數據類型
            <2009年7月>
            2829301234
            567891011
            12131415161718
            19202122232425
            2627282930311
            2345678

            常用鏈接

            留言簿(3)

            隨筆分類

            隨筆檔案

            文章分類

            文章檔案

            友情鏈接

            搜索

            •  

            最新評論

            閱讀排行榜

            評論排行榜

            久久人人爽人人爽人人片AV麻豆| 久久综合视频网| 亚洲国产精品久久久久| 久久久精品国产免大香伊| 久久久久99精品成人片试看| 久久国产影院| 国产成人综合久久久久久| 一本久久综合亚洲鲁鲁五月天亚洲欧美一区二区 | 三上悠亚久久精品| 国产精品99久久久久久猫咪| 久久伊人精品一区二区三区| 青青热久久国产久精品| 精品久久久久久久久午夜福利| 久久精品国产亚洲av麻豆图片 | 亚洲精品乱码久久久久久蜜桃| 久久免费美女视频| 亚洲国产欧洲综合997久久| 亚洲乱码精品久久久久..| 久久精品国产一区二区三区| 少妇高潮惨叫久久久久久| 日日躁夜夜躁狠狠久久AV| 欧美激情精品久久久久久久九九九| 久久99久久成人免费播放| 久久国产综合精品五月天| 国产精品免费看久久久| 久久人人爽人人人人片av| 国产A级毛片久久久精品毛片| 精品无码久久久久国产动漫3d| 人妻无码αv中文字幕久久琪琪布 人妻无码精品久久亚瑟影视 | 亚洲日本va中文字幕久久| 美女久久久久久| 久久亚洲精品无码播放| 久久久久久亚洲精品不卡| 狠狠色综合久久久久尤物| 99热热久久这里只有精品68| 狠狠色丁香久久综合五月| AV无码久久久久不卡蜜桃| 久久亚洲中文字幕精品有坂深雪| 欧美日韩中文字幕久久伊人| 久久精品国产亚洲精品| 麻豆精品久久久久久久99蜜桃|