文章作者:
yx_th000 文章來源:
Cherish_yimi (
http://www.cnblogs.com/cherish_yimi/) 轉載請注明,謝謝合作。
并查集學習--
并查集詳解The Suspects
Time Limit: 1000MS | | Memory Limit: 20000K |
Total Submissions: 5572 | | Accepted: 2660 |
Description
Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input
The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output
For each case, output the number of suspects in one line.
Sample Input
100 4 2 1 2 5 10 13 11 12 14 2 0 1 2 99 2 200 2 1 5 5 1 2 3 4 5 1 0 0 0
Sample Output
4 1 1
我的思路: 典型的并查集,最初各自為集,然后每個group進行合并,等到所有的group合并完,題目也就解決了,因為在合并的時候,如果哪兩個group中有重合的元素,則那個后來的group會由于按秩合并的原則自動合并到 先有的集合當中,奧妙便在其中。下面是代碼:

1
#include<iostream>
2
using namespace std;
3
4
int n, m, i, j;
5
int father[30005], num[30005];
6
7
void makeSet(int n)
8
{
9
for(i = 0; i < n; i++)
10
{
11
father[i] = i; //使用本身做根
12
num[i] = 1;
13
}
14
}
15
int findSet(int x)
16
{
17
if(father[x] != x) //合并后的樹的根是不變的
18
{
19
father[x] = findSet(father[x]);
20
}
21
return father[x];
22
}
23
24
void Union(int a, int b)
25
{
26
int x = findSet(a);
27
int y = findSet(b);
28
if(x == y)
29
{
30
return;
31
}
32
if(num[x] <= num[y])
33
{
34
father[x] = y;
35
num[y] += num[x];
36
}
37
else
38
{
39
father[y] = x;
40
num[x] += num[y];
41
}
42
}
43
44
int main()
45
{
46
while(scanf("%d %d", &n, &m)!=EOF && n != 0)
47
{
48
makeSet(n);
49
for(i = 0; i < m; i++)
50
{
51
int count, first, b;
52
scanf("%d %d",&count, &first);
53
for(j = 1; j < count; j++)
54
{
55
scanf("%d",&b);
56
Union(first,b);
57
}
58
}
59
printf("%d\n",num[findSet(0)]);
60
}
61
return 0;
62
}
63
posted on 2011-12-24 15:15
老馬驛站 閱讀(214)
評論(0) 編輯 收藏 引用 所屬分類:
c++