1. 將自己的電腦的本地連接屬性中的ip地址設(shè)置為192.168.1.2,掩碼設(shè)置為255.255.255.0,網(wǎng)關(guān)設(shè)置為192.168.1.12. 將wr703n用網(wǎng)線鏈接到電腦上
3. 瀏覽器中進入192.168.1.1,然后使用固件openwrt-ar71xx-generic-tl-wr703n-v1-squashfs-factory.bin升級路由器
4. 下載安裝兩個軟件,WinSCP(用于路由器與本地電腦之間的文件傳輸)、SecureCRT(SSH登入器)
5. 固件升級完之后重啟路由器,使用WinSCP連接進入路由器
6. 修改文件
文件:/etc/config/wireless
修改為:
config wifi-device 'radio0'
option type 'mac80211'
option channel '3'
option macaddr '14:e6:e4:e7:c6:a2'
option hwmode '11ng'
option htmode 'HT20'
list ht_capab 'SHORT-GI-20'
list ht_capab 'SHORT-GI-40'
list ht_capab 'RX-STBC1'
list ht_capab 'DSSS_CCK-40'
option disabled '0'
option txpower '27'
option country 'US'
config wifi-iface
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid '這里填無線網(wǎng)的名稱英文'
option encryption 'psk2'
option key '這里寫密碼八位'
文件:/etc/config/network
如果采用靜態(tài)網(wǎng)址就修改為:
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config interface 'wan'
option ifname 'eth0'
option _orig_ifname 'eth0'
option _orig_bridge 'false'
option proto 'static'
option ipaddr '這里寫你的靜態(tài)IP'
option netmask '寫子網(wǎng)掩碼'
option gateway '寫網(wǎng)關(guān)'
option dns '寫DNS'
config interface 'lan'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
文件:/etc/config/network
如果是自動獲取IP方式就修改為:
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config interface 'wan'
option ifname 'eth0'
option _orig_ifname 'eth0'
option _orig_bridge 'false'
option proto 'dhcp'
config interface 'lan'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
7. 將鏈接http://code.google.com/p/mentohust/issues/detail?id=175中的40K的mentohust下載復(fù)制到/usr/bin中,并通過chmod 755 mentohust命令對mentohust的文件屬性進行更改
8. 可以在/root/下建立runHust.sh的shell文件
文件:runHust.sh
內(nèi)容:
#! /bin/ash
mentohust -u***** -p**** -i***** -m***** -g*** -d0 -b0 -a1
9. 將路由器連接到校園網(wǎng)的網(wǎng)線接口上運行SecureCRT,執(zhí)行ash runHust.sh就能夠進行聯(lián)網(wǎng)
10. 連網(wǎng)期間不能夠中斷SecureCRT軟件
(有其它方式,請補充)