• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>
            posts - 3,  comments - 1,  trackbacks - 0
            學會了隊列.這道題的主要思想:

            5先入列   把5出列  5 可以變成 4 ,6 , 10, ,把得到的數入列,然后再出列分別處理..如果前面出現過就不入列..定義一個計數數組,然后number[y - 1] = number[y] + 1;  number[y + 1] = number[y] + 1; number[y * 2] = number[y] + 1;

            Catch That Cow
            Time Limit: 2000MS Memory Limit: 65536K
            Total Submissions: 8341 Accepted: 2476

            Description

            Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

            * Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
            * Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

            If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

            Input

            Line 1: Two space-separated integers: N and K

            Output

            Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

            Sample Input

            5 17

            Sample Output

            4

            Hint

            The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.




            Source Code

            Problem: 3278 User: luoguangyao
            Memory: 1048K Time: 110MS
            Language: C++ Result: Accepted
            • Source Code
              #include <iostream>
                  #include <queue>
                  using namespace::std;
                  int number[100001] = {0};
                  bool num[100001] = {0};
                  int main()
                  {
                  queue<int> x;
                  int a;
                  int b;
                  scanf("%d%d",&a,&b);
                  int count = 0;
                  number[a] = 0;
                  x.push(a);
                  while (x.size())
                  {
                  int y = x.front();
                  x.pop();
                  num[y] = 1;
                  if (y == b)
                  {
                  break;
                  }
                  else
                  {
                  if (y - 1 >= 0)
                  {
                  if (!num[y - 1])
                  {
                  x.push(y - 1);
                  number[y - 1] = number[y] + 1;
                  num[y - 1] = 1;
                  }
                  }
                  if (y + 1 <= 100000)
                  {
                  if (!num[y + 1])
                  {
                  x.push(y + 1);
                  number[y + 1] = number[y] + 1;
                  num[y + 1] = 1;
                  }
                  }
                  if (y * 2 <= 100000)
                  {
                  if (!num[y * 2])
                  {
                  x.push(y * 2);
                  number[y * 2] = number[y] + 1;
                  num[y * 2] = 1;
                  }
                  }
                  }
                  }
                  cout << number[b] << endl;
                  return 0;
                  }
            posted on 2009-03-07 18:33 生活要低調 閱讀(1799) 評論(0)  編輯 收藏 引用
            <2025年5月>
            27282930123
            45678910
            11121314151617
            18192021222324
            25262728293031
            1234567

            常用鏈接

            留言簿(1)

            隨筆檔案

            搜索

            •  

            最新評論

            閱讀排行榜

            評論排行榜

            蜜臀久久99精品久久久久久小说 | 国产精品日韩欧美久久综合| 精品久久久久久国产潘金莲| 久久久久久久97| 久久久久久久综合综合狠狠| 亚洲午夜精品久久久久久浪潮 | 无码乱码观看精品久久| 久久国产免费直播| segui久久国产精品| 2021国产精品久久精品| 嫩草影院久久99| 国内精品伊人久久久影院| 久久免费高清视频| 久久久国产打桩机| 久久久久亚洲AV无码专区桃色| 久久久久久久97| 久久久久18| 国产免费福利体检区久久| 久久精品天天中文字幕人妻| 无夜精品久久久久久| 国产成人无码精品久久久免费| 一本色道久久88—综合亚洲精品 | 色悠久久久久久久综合网 | 人妻无码久久精品| 91超碰碰碰碰久久久久久综合| 色婷婷综合久久久久中文一区二区| 亚洲国产精品成人久久蜜臀 | 久久久久人妻精品一区二区三区| 亚洲国产婷婷香蕉久久久久久| 青青国产成人久久91网| 久久精品亚洲精品国产色婷| 亚洲午夜久久久久久久久久| 中文无码久久精品| 久久精品中文字幕一区| 久久精品人人做人人爽电影| 一本一道久久a久久精品综合| 久久最新免费视频| 97视频久久久| 性欧美丰满熟妇XXXX性久久久 | 精品国产青草久久久久福利| 日韩精品国产自在久久现线拍|