• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>
            posts - 3,  comments - 1,  trackbacks - 0
            學會了隊列.這道題的主要思想:

            5先入列   把5出列  5 可以變成 4 ,6 , 10, ,把得到的數入列,然后再出列分別處理..如果前面出現過就不入列..定義一個計數數組,然后number[y - 1] = number[y] + 1;  number[y + 1] = number[y] + 1; number[y * 2] = number[y] + 1;

            Catch That Cow
            Time Limit: 2000MS Memory Limit: 65536K
            Total Submissions: 8341 Accepted: 2476

            Description

            Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

            * Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
            * Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

            If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

            Input

            Line 1: Two space-separated integers: N and K

            Output

            Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

            Sample Input

            5 17

            Sample Output

            4

            Hint

            The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.




            Source Code

            Problem: 3278 User: luoguangyao
            Memory: 1048K Time: 110MS
            Language: C++ Result: Accepted
            • Source Code
              #include <iostream>
                  #include <queue>
                  using namespace::std;
                  int number[100001] = {0};
                  bool num[100001] = {0};
                  int main()
                  {
                  queue<int> x;
                  int a;
                  int b;
                  scanf("%d%d",&a,&b);
                  int count = 0;
                  number[a] = 0;
                  x.push(a);
                  while (x.size())
                  {
                  int y = x.front();
                  x.pop();
                  num[y] = 1;
                  if (y == b)
                  {
                  break;
                  }
                  else
                  {
                  if (y - 1 >= 0)
                  {
                  if (!num[y - 1])
                  {
                  x.push(y - 1);
                  number[y - 1] = number[y] + 1;
                  num[y - 1] = 1;
                  }
                  }
                  if (y + 1 <= 100000)
                  {
                  if (!num[y + 1])
                  {
                  x.push(y + 1);
                  number[y + 1] = number[y] + 1;
                  num[y + 1] = 1;
                  }
                  }
                  if (y * 2 <= 100000)
                  {
                  if (!num[y * 2])
                  {
                  x.push(y * 2);
                  number[y * 2] = number[y] + 1;
                  num[y * 2] = 1;
                  }
                  }
                  }
                  }
                  cout << number[b] << endl;
                  return 0;
                  }
            posted on 2009-03-07 18:33 生活要低調 閱讀(1798) 評論(0)  編輯 收藏 引用
            <2025年5月>
            27282930123
            45678910
            11121314151617
            18192021222324
            25262728293031
            1234567

            常用鏈接

            留言簿(1)

            隨筆檔案

            搜索

            •  

            最新評論

            閱讀排行榜

            評論排行榜

            久久精品国产91久久综合麻豆自制| 久久福利青草精品资源站免费 | 亚洲中文久久精品无码| 久久国产精品偷99| 中文精品99久久国产| 深夜久久AAAAA级毛片免费看 | 无码人妻久久一区二区三区免费 | 国内高清久久久久久| 91精品国产乱码久久久久久 | 久久精品中文无码资源站| 久久国产精品一国产精品金尊| 久久精品亚洲中文字幕无码麻豆| 国产精品一区二区久久| 久久国产视频网| 国产精品久久久久久久人人看| 欧美成a人片免费看久久| 2021最新久久久视精品爱 | 一本色道久久88—综合亚洲精品| 国产成年无码久久久免费| 情人伊人久久综合亚洲| 久久午夜无码鲁丝片午夜精品| 亚洲精品国产字幕久久不卡 | 久久久久久av无码免费看大片| 亚洲国产美女精品久久久久∴ | 久久国产香蕉一区精品| 狠狠精品久久久无码中文字幕| 色综合久久精品中文字幕首页| 亚洲国产日韩综合久久精品| 久久最新精品国产| 久久香蕉超碰97国产精品| 久久久久18| 久久国产色AV免费观看| 亚洲国产日韩欧美久久| 国产成人无码精品久久久免费| 久久婷婷五月综合色高清| 麻豆av久久av盛宴av| 午夜精品久久久久久| 久久久久久噜噜精品免费直播| 成人精品一区二区久久| 青青青伊人色综合久久| 国产一级持黄大片99久久|