The Circumference of the Circle
本題在ZOJ上題號(hào)是1090,在POJ上是2242。題目描述如下:
Description
To calculate the circumference of a circle seems to be an easy task - provided you know its diameter. But what if you don't?
You are given the cartesian coordinates of three non-collinear points in the plane.
Your job is to calculate the circumference of the unique circle that intersects all three points.
Input
The input will contain one or more test cases. Each test case consists of one line containing six real numbers x1,y1, x2,y2,x3,y3, representing the coordinates of the three points. The diameter of the circle determined by the three points will never exceed a million. Input is terminated by end of file.
Output
For each test case, print one line containing one real number telling the circumference of the circle determined by the three points. The circumference is to be printed accurately rounded to two decimals. The value of pi is approximately 3.141592653589793.
Sample Input
0.0 -0.5 0.5 0.0 0.0 0.5
0.0 0.0 0.0 1.0 1.0 1.0
5.0 5.0 5.0 7.0 4.0 6.0
0.0 0.0 -1.0 7.0 7.0 7.0
50.0 50.0 50.0 70.0 40.0 60.0
0.0 0.0 10.0 0.0 20.0 1.0
0.0 -500000.0 500000.0 0.0 0.0 500000.0
Sample Output
3.14
4.44
6.28
31.42
62.83
632.24
3141592.65
分析:本題是一道比較容易的題,具體就考察了幾個(gè)數(shù)學(xué)公式的使用。本題的關(guān)鍵是求出內(nèi)接三角形的外接圓直徑。而在圓的內(nèi)接三角形的性質(zhì)中有這樣一條:三角形的任何兩邊的乘積的等于第三邊上的高于其外接圓直徑的乘積。這樣問題就轉(zhuǎn)化為求接三角形的某一邊上的高,在知道三角形三個(gè)頂點(diǎn)的情況下,求其面積應(yīng)該是件容易事,求得面積后,高的問題也就迎刃而解。求面積時(shí),由于本人較懶,用的是海倫公式:S = ,其中p = (a+b+c)/2,a,b,c分別為三角形的三個(gè)變長(zhǎng),S=0.5*c*h,即可求得h。a*b=h*d,那么直徑d也就出來了。具體代碼如下.
#include <stdio.h>
#include <stdlib.h>
#include <math.h>
int main(void)
{
double x1, y1, x2, y2, x3, y3;
double l1, l2, l3;
double p;
double h;
double d;
while (scanf("%lf%lf%lf%lf%lf%lf", &x1, &y1, &x2, &y2, &x3, &y3) == 6)
{
l1 = sqrt(pow(x1-x2, 2) + pow(y1-y2, 2));
l2 = sqrt(pow(x1-x3, 2) + pow(y1-y3, 2));
l3 = sqrt(pow(x2-x3, 2) + pow(y2-y3, 2));
p = (l1 + l2 + l3)/2;
h = sqrt(p*(p-l1)*(p-l2)*(p-l3))*2/l3;
d = l1*l2/h;
printf("%.2f\n", 3.141592653589793*d);
}
return 0;
}