• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            acm zoj1090解題報告

            Posted on 2010-09-19 22:44 李東亮 閱讀(1508) 評論(0)  編輯 收藏 引用
             

            The Circumference of the Circle

            本題在ZOJ上題號是1090,在POJ上是2242。題目描述如下:

            Description

            To calculate the circumference of a circle seems to be an easy task - provided you know its diameter. But what if you don't?

            You are given the cartesian coordinates of three non-collinear points in the plane.
            Your job is to calculate the circumference of the unique circle that intersects all three points.

            Input

            The input will contain one or more test cases. Each test case consists of one line containing six real numbers x1,y1, x2,y2,x3,y3, representing the coordinates of the three points. The diameter of the circle determined by the three points will never exceed a million. Input is terminated by end of file.

            Output

            For each test case, print one line containing one real number telling the circumference of the circle determined by the three points. The circumference is to be printed accurately rounded to two decimals. The value of pi is approximately 3.141592653589793.

            Sample Input

            0.0 -0.5 0.5 0.0 0.0 0.5

            0.0 0.0 0.0 1.0 1.0 1.0

            5.0 5.0 5.0 7.0 4.0 6.0

            0.0 0.0 -1.0 7.0 7.0 7.0

            50.0 50.0 50.0 70.0 40.0 60.0

            0.0 0.0 10.0 0.0 20.0 1.0

            0.0 -500000.0 500000.0 0.0 0.0 500000.0

            Sample Output

            3.14

            4.44

            6.28

            31.42

            62.83

            632.24

            3141592.65

            分析:本題是一道比較容易的題,具體就考察了幾個數學公式的使用。本題的關鍵是求出內接三角形的外接圓直徑。而在圓的內接三角形的性質中有這樣一條:三角形的任何兩邊的乘積的等于第三邊上的高于其外接圓直徑的乘積。這樣問題就轉化為求接三角形的某一邊上的高,在知道三角形三個頂點的情況下,求其面積應該是件容易事,求得面積后,高的問題也就迎刃而解。求面積時,由于本人較懶,用的是海倫公式:S = ,其中p = (a+b+c)/2abc分別為三角形的三個變長,S=0.5*c*h,即可求得ha*b=h*d,那么直徑d也就出來了。具體代碼如下.

            #include <stdio.h>

            #include <stdlib.h>

            #include <math.h>

            int main(void)

            {

                   double x1, y1, x2, y2, x3, y3;

                   double l1, l2, l3;

                   double p;

                   double h;

                   double d;

                   while (scanf("%lf%lf%lf%lf%lf%lf", &x1, &y1, &x2, &y2, &x3, &y3) == 6)

                   {

                          l1 = sqrt(pow(x1-x2, 2) + pow(y1-y2, 2));

                          l2 = sqrt(pow(x1-x3, 2) + pow(y1-y3, 2));

                          l3 = sqrt(pow(x2-x3, 2) + pow(y2-y3, 2));

                          p = (l1 + l2 + l3)/2;

                          h = sqrt(p*(p-l1)*(p-l2)*(p-l3))*2/l3;

                          d = l1*l2/h;

                          printf("%.2f\n", 3.141592653589793*d);

                   }

                   return 0;

            }

            posts - 12, comments - 1, trackbacks - 0, articles - 1

            Copyright © 李東亮

            国产精品久久国产精品99盘 | 久久免费观看视频| 欧美亚洲日本久久精品| 狠狠色丁香久久婷婷综合_中| 久久九九久精品国产免费直播| 性欧美丰满熟妇XXXX性久久久| 欧美综合天天夜夜久久| 综合久久一区二区三区 | 91超碰碰碰碰久久久久久综合| 欧美久久一区二区三区| 日韩人妻无码一区二区三区久久| 久久免费精品一区二区| 成人久久免费网站| 久久午夜福利电影| 精品免费tv久久久久久久| 欧美日韩精品久久久免费观看| 日本精品久久久久中文字幕8| 狠狠色噜噜色狠狠狠综合久久| 久久99精品久久久久久噜噜| 久久精品aⅴ无码中文字字幕不卡 久久精品aⅴ无码中文字字幕重口 | 国内精品久久久久久久久电影网| 亚洲精品国产成人99久久| 久久久久久久91精品免费观看| 久久国产一区二区| 热re99久久精品国99热| 国产成人精品三上悠亚久久| 久久伊人色| 亚洲日本久久久午夜精品| 免费一级做a爰片久久毛片潮| 久久久久国产精品| 久久综合久久综合久久| 97久久综合精品久久久综合| 精品久久久久久久无码| 久久99精品久久久久子伦| 久久亚洲精品无码AV红樱桃| 漂亮人妻被黑人久久精品| 亚洲第一极品精品无码久久| 亚洲欧美成人综合久久久| 久久久国产乱子伦精品作者| 久久久久久久97| 9191精品国产免费久久|