• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>
            posts - 74,  comments - 33,  trackbacks - 0

            Description

            Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.

            For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

            You are to write a program that will count the amounts of the stars of each level on a given map.

            Input

            The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

            Output

            The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

            Sample Input

            5
            1 1
            5 1
            7 1
            3 3
            5 5

            Sample Output

            1
            2
            1
            1
            0
            神啊原諒我吧我很菜!
            看了樹狀數組還沒思路!
            代碼ac后更新
            posted on 2009-01-10 10:24 KNIGHT 閱讀(173) 評論(1)  編輯 收藏 引用

            FeedBack:
            # re: Stars[未登錄]
            2009-01-12 10:01 | Knight
            #include<stdio.h>
            #define SIZE1 32000
            #define SIZE2 15000
            int c[SIZE1],a[SIZE1],out[SIZE2],n;
            int lowbit(int k)
            {
            return k&(-k);
            }
            int sum(int k)
            {
            int ret=0;
            while(k>0)
            {
            ret+=c[k];
            k-=lowbit(k);
            }
            return ret;
            }
            void change(int pos,int delt)
            {
            while(pos<=SIZE1)
            {
            c[pos]+=delt;
            pos+=lowbit(pos);
            }
            }
            void init()
            {
            int i;
            int x,y;
            for(i=0;i<n;i++)
            {
            scanf("%d%d",&x,&y);
            x++;
            out[sum(x-1)+a[x]]++;
            change(x,1);
            a[x]++;
            }
            }
            int main()
            {
            int i;
            scanf("%d",&n);
            init();
            for(i=0;i<n;i++)
            printf("%d\n",out[i]);
            }
            pip來了,但是他說他也不會他是線段樹過的。。。。。
            線段樹。。。。。代碼不是我的。。。網上的。。。。不過不錯。。。題目有個條件就是按y升序給出數據。。。。所以可以用樹狀數組,其實可以排序在用的。。。。。繼續物理。。。。關機。。。  回復  更多評論
              
            <2009年2月>
            25262728293031
            1234567
            891011121314
            15161718192021
            22232425262728
            1234567

            常用鏈接

            留言簿(8)

            隨筆檔案

            文章檔案

            Friends

            OJ

            搜索

            •  

            最新評論

            閱讀排行榜

            評論排行榜

            久久人人爽人人爽人人av东京热| 亚洲国产精品成人久久| 婷婷久久综合| 久久精品天天中文字幕人妻| 日本久久久久久中文字幕| 香蕉久久AⅤ一区二区三区| 潮喷大喷水系列无码久久精品| 久久亚洲高清综合| 精品久久久久久国产| 蜜桃麻豆WWW久久囤产精品| 欧美亚洲另类久久综合| 国色天香久久久久久久小说 | 久久精品国产免费观看| 国产亚洲欧美精品久久久| 婷婷久久综合九色综合绿巨人| 国产精品禁18久久久夂久| 亚洲国产天堂久久综合| 伊人久久综在合线亚洲2019| 99精品久久久久久久婷婷| 久久天天躁狠狠躁夜夜2020| 久久精品一区二区三区不卡| 国内精品久久久久影院薰衣草| 久久亚洲中文字幕精品一区| 国产精品免费久久| 99久久国产主播综合精品| 国产午夜精品理论片久久影视| 欧美黑人又粗又大久久久| 久久久亚洲AV波多野结衣| 婷婷久久综合九色综合九七| 精品久久国产一区二区三区香蕉 | 久久久亚洲AV波多野结衣| 久久亚洲国产成人影院网站| 精品视频久久久久| 久久免费视频6| 一本久久免费视频| 波多野结衣久久一区二区| 久久久久久综合网天天| 亚洲狠狠婷婷综合久久久久| 人妻精品久久久久中文字幕69| 亚洲AV无一区二区三区久久| 亚洲欧美成人综合久久久|