• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>
            posts - 74,  comments - 33,  trackbacks - 0

            Description

            Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.

            For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

            You are to write a program that will count the amounts of the stars of each level on a given map.

            Input

            The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

            Output

            The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

            Sample Input

            5
            1 1
            5 1
            7 1
            3 3
            5 5

            Sample Output

            1
            2
            1
            1
            0
            神啊原諒我吧我很菜!
            看了樹狀數組還沒思路!
            代碼ac后更新
            posted on 2009-01-10 10:24 KNIGHT 閱讀(173) 評論(1)  編輯 收藏 引用

            FeedBack:
            # re: Stars[未登錄]
            2009-01-12 10:01 | Knight
            #include<stdio.h>
            #define SIZE1 32000
            #define SIZE2 15000
            int c[SIZE1],a[SIZE1],out[SIZE2],n;
            int lowbit(int k)
            {
            return k&(-k);
            }
            int sum(int k)
            {
            int ret=0;
            while(k>0)
            {
            ret+=c[k];
            k-=lowbit(k);
            }
            return ret;
            }
            void change(int pos,int delt)
            {
            while(pos<=SIZE1)
            {
            c[pos]+=delt;
            pos+=lowbit(pos);
            }
            }
            void init()
            {
            int i;
            int x,y;
            for(i=0;i<n;i++)
            {
            scanf("%d%d",&x,&y);
            x++;
            out[sum(x-1)+a[x]]++;
            change(x,1);
            a[x]++;
            }
            }
            int main()
            {
            int i;
            scanf("%d",&n);
            init();
            for(i=0;i<n;i++)
            printf("%d\n",out[i]);
            }
            pip來了,但是他說他也不會他是線段樹過的。。。。。
            線段樹。。。。。代碼不是我的。。。網上的。。。。不過不錯。。。題目有個條件就是按y升序給出數據。。。。所以可以用樹狀數組,其實可以排序在用的。。。。。繼續物理。。。。關機。。。  回復  更多評論
              
            <2009年5月>
            262728293012
            3456789
            10111213141516
            17181920212223
            24252627282930
            31123456

            常用鏈接

            留言簿(8)

            隨筆檔案

            文章檔案

            Friends

            OJ

            搜索

            •  

            最新評論

            閱讀排行榜

            評論排行榜

            久久人人爽人爽人人爽av| 久久综合亚洲鲁鲁五月天| 久久美女人爽女人爽| 国内精品久久久久久久影视麻豆| 精品乱码久久久久久夜夜嗨| 久久久久久午夜精品| 久久精品国产亚洲av水果派| 国产精自产拍久久久久久蜜| 久久精品国产亚洲AV影院| 国内精品久久久久伊人av| 久久亚洲国产成人精品无码区| 日韩精品久久无码人妻中文字幕| 久久精品嫩草影院| 亚洲愉拍99热成人精品热久久 | 久久精品国产清自在天天线| 久久久网中文字幕| 久久国产精品-久久精品| 伊人久久精品无码二区麻豆| 国产精品欧美久久久久天天影视| 久久久无码精品亚洲日韩按摩| 欧洲国产伦久久久久久久 | 99久久国产免费福利| 午夜精品久久久久久毛片| 四虎久久影院| 美女久久久久久| 久久免费99精品国产自在现线 | 欧美日韩精品久久久免费观看| 精品国产一区二区三区久久久狼 | 激情五月综合综合久久69| 久久久久无码精品国产| 久久天天躁夜夜躁狠狠躁2022| 亚洲伊人久久成综合人影院 | 午夜精品久久久久久毛片| 久久成人小视频| 伊人色综合久久天天网| 亚洲日本久久久午夜精品| 四虎亚洲国产成人久久精品| 人妻中文久久久久| 免费精品久久天干天干| 亚洲伊人久久大香线蕉综合图片| 久久久久久久久无码精品亚洲日韩 |