• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>
            posts - 74,  comments - 33,  trackbacks - 0
            ChiBi

            Time Limit: 5 Seconds      Memory Limit: 32768 KB

            watashi's mm is so pretty as well as smart. Recently, she has watched the movie Chibi. So she knows more about the War of ChiBi. In the war, Cao Cao had 800,000 soldiers, much more than his opponents'. But he was defeated. One of the mistakes he made was that he connected some of his boats together, and these boats were burned by the clever opponents.

            Then an interesting problem occurs to watashi's mm. She wants to use this problem to check whether watashi is as smart as her. However, watashi has no idea about the problem. So he turns to you for help.

            You know whether two boats are directly connected and the distance between them. And Fire's speed to spread between boats is 1m/s. You also know the time your soldiers need to travel from your camp to each boat. Because burning Cao Cao's boat is a very dangerous job, you must choose the least number of soldiers, and each one can only burn one boat. How much time do you need to burn all the Cao Cao's boats?

            Input

            The input contains several test cases. Each test case begins with a line contains only one integer 0 <= N <= 1000, which indicates the number of boats. The next N lines, each line contains N integers in range [0, 10000], the jth number in the ith line is the distance in metre between the ith boat and the jth boat, if the number is -1, then these two boats are not directly connected (d(i, j) == d(j, i) && d(i, i) == 0). Then N intergers in range [0, 10000], the ith number is the time in second your soldiers need to travel from the camp to the ith boat. What's more Cao Cao is not that stupid, so he won't connect more than 100 boats together.

            Output

            The shortest time you need to burn all the Cao Cao's boats counting from the soldiers leave the camp in a single line.

            Sample input

            4
            0 1 2 -1
            1 0 4 -1
            2 4 0 -1
            -1 -1 -1 0
            1 2 4 8
            

            Sample Output

            8
            該死的-1 我一直調試的代碼最后發現自己的-1居然沒處理
            暈死
            代碼如下
             1#include<stdio.h>
             2int map[1010][1010],flag[1010];
             3int time[1010];
             4int main()
             5{
             6    int n,i,j,k,sum,min;
             7    while(scanf("%d",&n)!=EOF)
             8    {
             9        for(i=0;i<n;i++)
            10        {
            11            for(j=0;j<n;j++)
            12                scanf("%d",&map[i][j]);
            13            flag[i]=0;
            14        }

            15        for(i=0;i<n;i++)
            16            scanf("%d",&time[i]);
            17        for(k=0;k<n;k++)
            18            for(i=0;i<n;i++)
            19                if(i!=k&&map[i][k]>=0)
            20                    for(j=0;j<n;j++)
            21                        if(j!=k&&map[k][j]>=0)
            22                        {
            23                            if(map[i][j]==-1)map[i][j]=map[i][k]+map[k][j];
            24                            else if(map[i][k]+map[k][j]<map[i][j])map[i][j]=map[i][k]+map[k][j];
            25                        }

            26        for(i=0;i<n;i++)
            27        {
            28            int max=0;
            29            for(j=0;j<n;j++)
            30                if(map[i][j]>max)max=map[i][j];
            31            time[i]+=max;    
            32        }

            33        sum=0;
            34        for(i=0;i<n;i++)
            35        {
            36            if(!flag[i])
            37            {
            38                flag[i]=1;
            39                min=time[i];
            40                for(j=0;j<n;j++)
            41                    if(map[i][j]>=0&&!flag[j])
            42                    {
            43                        flag[j]=1;
            44                        if(min>time[j])min=time[j];    
            45                    }

            46            }

            47            if(sum<min)sum=min;    
            48        }

            49        printf("%d\n",sum);            
            50    }
                
            51}

            52Floyd思路
            posted on 2008-12-27 14:42 KNIGHT 閱讀(144) 評論(0)  編輯 收藏 引用
            <2009年2月>
            25262728293031
            1234567
            891011121314
            15161718192021
            22232425262728
            1234567

            常用鏈接

            留言簿(8)

            隨筆檔案

            文章檔案

            Friends

            OJ

            搜索

            •  

            最新評論

            閱讀排行榜

            評論排行榜

            伊人久久一区二区三区无码| 精品久久久无码人妻中文字幕豆芽| 国产一区二区精品久久岳 | 久久久精品日本一区二区三区| 大美女久久久久久j久久| 中文字幕无码久久人妻| 久久久久人妻精品一区二区三区 | 2020久久精品亚洲热综合一本| 亚洲色欲久久久综合网东京热| 99久久综合狠狠综合久久| 伊人久久无码精品中文字幕| 国产日产久久高清欧美一区| 亚洲人AV永久一区二区三区久久 | 色综合久久久久久久久五月| 精品久久久久久无码免费| 久久久久人妻一区二区三区vr| 中文成人无码精品久久久不卡 | 久久这里只有精品视频99| 国产精品久久久久久久久免费| 久久久久久久免费视频| 99久久www免费人成精品| 精品国产乱码久久久久久1区2区 | 天天影视色香欲综合久久| 97久久久久人妻精品专区| 亚洲欧美伊人久久综合一区二区 | 奇米影视7777久久精品人人爽 | 成人精品一区二区久久久| 久久精品国产清高在天天线| 一本久道久久综合狠狠爱| 亚洲&#228;v永久无码精品天堂久久| 久久久久久狠狠丁香| 99久久国产综合精品麻豆| 久久国产精品77777| 亚洲狠狠婷婷综合久久蜜芽| 中文国产成人精品久久亚洲精品AⅤ无码精品 | 伊人久久综合精品无码AV专区| 久久国产成人精品麻豆| 久久免费视频观看| 国产精品热久久毛片| 久久无码一区二区三区少妇| 亚洲国产成人精品久久久国产成人一区二区三区综 |