• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>
            posts - 74,  comments - 33,  trackbacks - 0
            ChiBi

            Time Limit: 5 Seconds      Memory Limit: 32768 KB

            watashi's mm is so pretty as well as smart. Recently, she has watched the movie Chibi. So she knows more about the War of ChiBi. In the war, Cao Cao had 800,000 soldiers, much more than his opponents'. But he was defeated. One of the mistakes he made was that he connected some of his boats together, and these boats were burned by the clever opponents.

            Then an interesting problem occurs to watashi's mm. She wants to use this problem to check whether watashi is as smart as her. However, watashi has no idea about the problem. So he turns to you for help.

            You know whether two boats are directly connected and the distance between them. And Fire's speed to spread between boats is 1m/s. You also know the time your soldiers need to travel from your camp to each boat. Because burning Cao Cao's boat is a very dangerous job, you must choose the least number of soldiers, and each one can only burn one boat. How much time do you need to burn all the Cao Cao's boats?

            Input

            The input contains several test cases. Each test case begins with a line contains only one integer 0 <= N <= 1000, which indicates the number of boats. The next N lines, each line contains N integers in range [0, 10000], the jth number in the ith line is the distance in metre between the ith boat and the jth boat, if the number is -1, then these two boats are not directly connected (d(i, j) == d(j, i) && d(i, i) == 0). Then N intergers in range [0, 10000], the ith number is the time in second your soldiers need to travel from the camp to the ith boat. What's more Cao Cao is not that stupid, so he won't connect more than 100 boats together.

            Output

            The shortest time you need to burn all the Cao Cao's boats counting from the soldiers leave the camp in a single line.

            Sample input

            4
            0 1 2 -1
            1 0 4 -1
            2 4 0 -1
            -1 -1 -1 0
            1 2 4 8
            

            Sample Output

            8
            該死的-1 我一直調試的代碼最后發現自己的-1居然沒處理
            暈死
            代碼如下
             1#include<stdio.h>
             2int map[1010][1010],flag[1010];
             3int time[1010];
             4int main()
             5{
             6    int n,i,j,k,sum,min;
             7    while(scanf("%d",&n)!=EOF)
             8    {
             9        for(i=0;i<n;i++)
            10        {
            11            for(j=0;j<n;j++)
            12                scanf("%d",&map[i][j]);
            13            flag[i]=0;
            14        }

            15        for(i=0;i<n;i++)
            16            scanf("%d",&time[i]);
            17        for(k=0;k<n;k++)
            18            for(i=0;i<n;i++)
            19                if(i!=k&&map[i][k]>=0)
            20                    for(j=0;j<n;j++)
            21                        if(j!=k&&map[k][j]>=0)
            22                        {
            23                            if(map[i][j]==-1)map[i][j]=map[i][k]+map[k][j];
            24                            else if(map[i][k]+map[k][j]<map[i][j])map[i][j]=map[i][k]+map[k][j];
            25                        }

            26        for(i=0;i<n;i++)
            27        {
            28            int max=0;
            29            for(j=0;j<n;j++)
            30                if(map[i][j]>max)max=map[i][j];
            31            time[i]+=max;    
            32        }

            33        sum=0;
            34        for(i=0;i<n;i++)
            35        {
            36            if(!flag[i])
            37            {
            38                flag[i]=1;
            39                min=time[i];
            40                for(j=0;j<n;j++)
            41                    if(map[i][j]>=0&&!flag[j])
            42                    {
            43                        flag[j]=1;
            44                        if(min>time[j])min=time[j];    
            45                    }

            46            }

            47            if(sum<min)sum=min;    
            48        }

            49        printf("%d\n",sum);            
            50    }
                
            51}

            52Floyd思路
            posted on 2008-12-27 14:42 KNIGHT 閱讀(144) 評論(0)  編輯 收藏 引用
            <2009年5月>
            262728293012
            3456789
            10111213141516
            17181920212223
            24252627282930
            31123456

            常用鏈接

            留言簿(8)

            隨筆檔案

            文章檔案

            Friends

            OJ

            搜索

            •  

            最新評論

            閱讀排行榜

            評論排行榜

            久久99国产精品久久99果冻传媒| 国产午夜精品久久久久九九电影 | 久久久久av无码免费网| 97久久国产综合精品女不卡| 国产麻豆精品久久一二三| 久久精品国产影库免费看| 欧美一级久久久久久久大片| 伊人久久大香线蕉综合Av| 久久精品成人国产午夜| 伊人久久成人成综合网222| 久久久久久久人妻无码中文字幕爆| 欧美久久精品一级c片片| 少妇熟女久久综合网色欲| 久久国产成人精品麻豆| 中文字幕无码久久久| 日本一区精品久久久久影院| 亚洲精品蜜桃久久久久久| 精品久久人人妻人人做精品| 日韩av无码久久精品免费| 欧美日韩中文字幕久久久不卡| 99久久精品毛片免费播放| 国产69精品久久久久观看软件| 久久午夜电影网| 国产精品久久久久久影院| 色欲久久久天天天综合网精品| 亚洲精品午夜国产va久久 | 国产亚洲色婷婷久久99精品91 | 狠狠色噜噜狠狠狠狠狠色综合久久| 思思久久99热只有频精品66| 国产一区二区精品久久凹凸| 精品亚洲综合久久中文字幕| 精品久久久久久无码中文字幕一区| 亚洲国产精品一区二区久久hs| 狠狠色丁香婷婷久久综合| 亚洲国产成人久久笫一页| 无码乱码观看精品久久| 中文字幕亚洲综合久久菠萝蜜| 热综合一本伊人久久精品| 国内精品久久国产| 亚洲国产精品久久电影欧美| 久久亚洲中文字幕精品有坂深雪|