• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>
            付翔的專欄
            在鄙視中成長 記錄成長的點滴
            posts - 106,  comments - 32,  trackbacks - 0

            Function Run Fun
            Time Limit: 1000MS  Memory Limit: 10000K
            Total Submissions: 6420  Accepted: 3526

            Description

            We all love recursion! Don't we?

            Consider a three-parameter recursive function w(a, b, c):

            if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns:
            1

            if a > 20 or b > 20 or c > 20, then w(a, b, c) returns:
            w(20, 20, 20)

            if a < b and b < c, then w(a, b, c) returns:
            w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c)

            otherwise it returns:
            w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1)

            This is an easy function to implement. The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion.

            Input

            The input for your program will be a series of integer triples, one per line, until the end-of-file flag of -1 -1 -1. Using the above technique, you are to calculate w(a, b, c) efficiently and print the result.
            Output

            Print the value for w(a,b,c) for each triple.
            Sample Input

            1 1 1
            2 2 2
            10 4 6
            50 50 50
            -1 7 18
            -1 -1 -1
            Sample Output

            w(1, 1, 1) = 2
            w(2, 2, 2) = 4
            w(10, 4, 6) = 523
            w(50, 50, 50) = 1048576
            w(-1, 7, 18) = 1

             

            #include<stdio.h>
            long data[21][21][21= {0};
            int fun(int a,int b,int c)//根據題意來寫函數
            {
            if(a<=0||b<=0||c<=0)
            return 1;
            else if(a>20||b>20||c>20)
            return fun(20,20,20);
            if(data[a][b][c])//要是 data已經存在的話就直接返回值
            return data[a][b][c];
            else if(a<b&&b<c)
            return fun(a, b, c-1+ fun(a, b-1, c-1- fun(a, b-1, c);
            else
            return fun(a-1, b, c) + fun(a-1, b-1, c) + fun(a-1, b, c-1- fun(a-1, b-1, c-1);
            }

            int main()
            {
            int a, b ,c;//三維
            data[0][0][0= 1;
            for(a = 0;a<=20;a++)
            for(b = 0;b<=20; b++)
            for(c = 0;c <=20; c ++)
            {
            data[a][b][c] 
            = fun(a,b,c);
            }

            while(scanf("%d%d%d",&a,&b,&c)!=EOF)
            {
            if(a==-1&&b==-1&&c==-1)
            return 1;
            printf(
            "w(%d, %d, %d) = %d\n",a,b,c,fun(a,b,c));
            }

            return 0;
            }


             

            posted on 2009-08-06 21:00 付翔 閱讀(859) 評論(0)  編輯 收藏 引用

            <2009年11月>
            25262728293031
            1234567
            891011121314
            15161718192021
            22232425262728
            293012345

            常用鏈接

            留言簿(2)

            隨筆分類

            隨筆檔案

            文章分類

            文章檔案

            CSDN - 我的blog地址

            博客

            搜索

            •  

            最新評論

            閱讀排行榜

            評論排行榜

            亚洲国产成人久久一区久久 | 久久夜色精品国产www| 久久综合久久综合久久| 99久久婷婷国产综合精品草原| 国产99久久久国产精免费| 免费精品国产日韩热久久| 一本久道久久综合狠狠爱| 婷婷久久综合九色综合98| 亚洲午夜久久久| 久久本道伊人久久| 久久受www免费人成_看片中文| 久久99国产综合精品| 久久精品国产色蜜蜜麻豆| 日本久久久久亚洲中字幕| 国内精品久久久久久久久电影网| 伊人久久亚洲综合影院| 久久精品国产69国产精品亚洲| 久久久精品波多野结衣| 91精品国产综合久久久久久| 日韩一区二区三区视频久久 | 久久99热狠狠色精品一区| 中文字幕无码av激情不卡久久| 国产精品久久99| 午夜精品久久久久久久久| 久久一本综合| 国产精品成人无码久久久久久| 国内精品人妻无码久久久影院导航| 国产精品免费久久久久久久久 | 久久人人爽爽爽人久久久| 亚洲AV伊人久久青青草原| 国产免费久久久久久无码| 国产99精品久久| 国产精品99精品久久免费| 亚洲乱码中文字幕久久孕妇黑人 | 欧美精品一本久久男人的天堂| 无遮挡粉嫩小泬久久久久久久| 亚洲色大成网站www久久九| 国产精品亚洲综合久久| 日韩影院久久| 综合久久国产九一剧情麻豆| 一本一本久久A久久综合精品 |