• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>
            付翔的專欄
            在鄙視中成長 記錄成長的點(diǎn)滴
            posts - 106,  comments - 32,  trackbacks - 0

            Function Run Fun
            Time Limit: 1000MS  Memory Limit: 10000K
            Total Submissions: 6420  Accepted: 3526

            Description

            We all love recursion! Don't we?

            Consider a three-parameter recursive function w(a, b, c):

            if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns:
            1

            if a > 20 or b > 20 or c > 20, then w(a, b, c) returns:
            w(20, 20, 20)

            if a < b and b < c, then w(a, b, c) returns:
            w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c)

            otherwise it returns:
            w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1)

            This is an easy function to implement. The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion.

            Input

            The input for your program will be a series of integer triples, one per line, until the end-of-file flag of -1 -1 -1. Using the above technique, you are to calculate w(a, b, c) efficiently and print the result.
            Output

            Print the value for w(a,b,c) for each triple.
            Sample Input

            1 1 1
            2 2 2
            10 4 6
            50 50 50
            -1 7 18
            -1 -1 -1
            Sample Output

            w(1, 1, 1) = 2
            w(2, 2, 2) = 4
            w(10, 4, 6) = 523
            w(50, 50, 50) = 1048576
            w(-1, 7, 18) = 1

             

            #include<stdio.h>
            long data[21][21][21= {0};
            int fun(int a,int b,int c)//根據(jù)題意來寫函數(shù)
            {
            if(a<=0||b<=0||c<=0)
            return 1;
            else if(a>20||b>20||c>20)
            return fun(20,20,20);
            if(data[a][b][c])//要是 data已經(jīng)存在的話就直接返回值
            return data[a][b][c];
            else if(a<b&&b<c)
            return fun(a, b, c-1+ fun(a, b-1, c-1- fun(a, b-1, c);
            else
            return fun(a-1, b, c) + fun(a-1, b-1, c) + fun(a-1, b, c-1- fun(a-1, b-1, c-1);
            }

            int main()
            {
            int a, b ,c;//三維
            data[0][0][0= 1;
            for(a = 0;a<=20;a++)
            for(b = 0;b<=20; b++)
            for(c = 0;c <=20; c ++)
            {
            data[a][b][c] 
            = fun(a,b,c);
            }

            while(scanf("%d%d%d",&a,&b,&c)!=EOF)
            {
            if(a==-1&&b==-1&&c==-1)
            return 1;
            printf(
            "w(%d, %d, %d) = %d\n",a,b,c,fun(a,b,c));
            }

            return 0;
            }


             

            posted on 2009-08-06 21:00 付翔 閱讀(859) 評論(0)  編輯 收藏 引用

            只有注冊用戶登錄后才能發(fā)表評論。
            網(wǎng)站導(dǎo)航: 博客園   IT新聞   BlogJava   博問   Chat2DB   管理



            <2010年5月>
            2526272829301
            2345678
            9101112131415
            16171819202122
            23242526272829
            303112345

            常用鏈接

            留言簿(2)

            隨筆分類

            隨筆檔案

            文章分類

            文章檔案

            CSDN - 我的blog地址

            博客

            搜索

            •  

            最新評論

            閱讀排行榜

            評論排行榜

            99久久精品免费看国产免费| 久久久久人妻精品一区二区三区| 久久成人精品视频| 青青草原综合久久| 欧美国产精品久久高清| 亚洲精品午夜国产VA久久成人| 久久久久亚洲Av无码专| 国内精品欧美久久精品| 97精品依人久久久大香线蕉97| 国产91色综合久久免费| 一97日本道伊人久久综合影院| 99999久久久久久亚洲| 久久精品国产亚洲一区二区三区| 无码人妻久久一区二区三区| 国内精品久久久久久久亚洲| 性欧美丰满熟妇XXXX性久久久| 久久精品视频网| 亚洲级αV无码毛片久久精品| 国产精品xxxx国产喷水亚洲国产精品无码久久一区 | 久久天天躁狠狠躁夜夜2020一| 久久丫精品国产亚洲av不卡| 少妇久久久久久被弄到高潮| A级毛片无码久久精品免费| 久久青青草视频| 久久国产三级无码一区二区| 国产精品久久久久影院色| 中文字幕人妻色偷偷久久| 日批日出水久久亚洲精品tv| 久久久久国产精品| 国产精品久久久久久影院| 久久综合九色综合网站| 99久久这里只精品国产免费| 欧美性猛交xxxx免费看久久久| 久久国产精品免费| 久久久久久亚洲精品不卡 | 日韩一区二区久久久久久 | 国内精品久久久久久久亚洲| AV狠狠色丁香婷婷综合久久 | 浪潮AV色综合久久天堂| 国产精品99久久久精品无码 | 人妻精品久久无码区|