• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            一道極其簡(jiǎn)單的ACM題,為什么第2段代碼通不過測(cè)試?
            http://acm.hziee.edu.cn/showproblem.php?pid=1096

            題目
            Your task is to calculate the sum of some integers.

            Input
            Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.

            Output
            For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.

            Sample Input
            3
            4 1 2 3 4
            5 1 2 3 4 5
            3 1 2 3

            Sample Output
            10
            15
            6

            第一段代碼,通過測(cè)試
            # include <iostream>
            using namespace std;
            int main()
            {
            ?int m,n,s;
            ?int sum;
            ?cin>>n;
            ?for(int i=0;i<n;i++)
            ?{
            ??if(i)
            ???cout<<endl;
            ??cin>>m;
            ??sum=0;
            ??for(int j=0;j<m;j++)
            ??{
            ???cin>>s;
            ???sum+=s;
            ??}
            ??cout<<sum<<endl;
            ?}
            ?return 0;
            }

            第2段代碼,通不過測(cè)試,why?
            #include <iostream>
            #include <vector>
            #include <numeric>
            #include <string>
            #include <sstream>
            using namespace std;
            int main(void)
            {
            int times;
            cin>>times;
            while(times--!=-1){
            ??????? string str;
            ??????? istringstream istr;
            ??????? int temp;

            ??????? getline(cin,str);
            ??????? istr.str(str);
            ??????? vector<int> array;
            ???????
            ??????? bool ignore=true;
            ??????? while(!istr.eof()){
            ?????????? istr>>temp;??????????????????????????
            ?????????? if(ignore==true) {ignore=false;continue;}?????
            ?????????? array.push_back(temp);
            ?????????? }
            ??????? if(!array.empty()) cout<<accumulate(array.begin(), array.end(),0)<<"\n"<<endl;???
            ?}

            return 0;
            }

            有時(shí)候第2段代碼會(huì)得出奇怪的結(jié)果,這是為什么?

            posted on 2006-04-19 01:48 張沈鵬 閱讀(320) 評(píng)論(2)  編輯 收藏 引用
            Comments
            • # re: 一道極其簡(jiǎn)單的ACM題,為什么第2段代碼通不過測(cè)試?
              任我行
              Posted @ 2006-04-20 08:24
              寫的真亂。下面寫法為什么意思?
              bool ignore=true;
              while(!istr.eof()){
              istr>>temp;
              if(ignore==true){
              ignore=false;
              continue;
              }
              array.push_back(temp);
              }
                回復(fù)  更多評(píng)論   
            • # re: 一道極其簡(jiǎn)單的ACM題,為什么第2段代碼通不過測(cè)試?
              me
              Posted @ 2006-04-22 16:04
              就是忽略第一個(gè)數(shù),把string轉(zhuǎn)為int放入vector中  回復(fù)  更多評(píng)論   

            只有注冊(cè)用戶登錄后才能發(fā)表評(píng)論。
            網(wǎng)站導(dǎo)航: 博客園   IT新聞   BlogJava   博問   Chat2DB   管理


             
            亚洲国产精品无码久久久蜜芽 | 国内精品久久久久影院老司| www性久久久com| 亚洲级αV无码毛片久久精品| 欧美性大战久久久久久| 久久精品国产亚洲av瑜伽| 国产精品亚洲综合专区片高清久久久| 国产综合久久久久| 国内精品伊人久久久久| 久久九九亚洲精品| 国产999精品久久久久久| 久久久青草青青亚洲国产免观| 久久久久久久久久久久中文字幕 | 99久久夜色精品国产网站| 精品多毛少妇人妻AV免费久久| 精品国产99久久久久久麻豆| 一本久久a久久精品vr综合| 久久综合给合久久国产免费| …久久精品99久久香蕉国产| 99久久精品费精品国产一区二区| 99久久免费只有精品国产| 香蕉99久久国产综合精品宅男自 | 亚洲人成无码久久电影网站| 一本综合久久国产二区| 亚洲精品乱码久久久久久久久久久久| 久久不见久久见免费视频7| 久久精品免费观看| 亚洲国产精品无码久久九九| 久久久无码人妻精品无码| 情人伊人久久综合亚洲| 欧美一级久久久久久久大| 久久精品亚洲日本波多野结衣| 91久久九九无码成人网站| 久久久无码精品亚洲日韩京东传媒| 精品久久久久香蕉网| 一级做a爰片久久毛片看看| 精品免费tv久久久久久久| 欧美久久亚洲精品| 色综合久久精品中文字幕首页| 久久受www免费人成_看片中文| 久久99国产精品久久99|