• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>
            posts - 3,  comments - 1,  trackbacks - 0
              2009年3月8日
                 摘要: 第N道的廣搜,這幾天就準備做廣搜了...真的需要好好練習下... Prime Path Time Limit: 1000MS Memory Limit: 65536K Total Submissions: 187...  閱讀全文
            posted @ 2009-03-08 11:23 生活要低調 閱讀(1441) | 評論 (1)編輯 收藏
              2009年3月7日
            學會了隊列.這道題的主要思想:

            5先入列   把5出列  5 可以變成 4 ,6 , 10, ,把得到的數入列,然后再出列分別處理..如果前面出現過就不入列..定義一個計數數組,然后number[y - 1] = number[y] + 1;  number[y + 1] = number[y] + 1; number[y * 2] = number[y] + 1;

            Catch That Cow
            Time Limit: 2000MS Memory Limit: 65536K
            Total Submissions: 8341 Accepted: 2476

            Description

            Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

            * Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
            * Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

            If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

            Input

            Line 1: Two space-separated integers: N and K

            Output

            Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

            Sample Input

            5 17

            Sample Output

            4

            Hint

            The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.




            Source Code

            Problem: 3278 User: luoguangyao
            Memory: 1048K Time: 110MS
            Language: C++ Result: Accepted
            • Source Code
              #include <iostream>
                  #include <queue>
                  using namespace::std;
                  int number[100001] = {0};
                  bool num[100001] = {0};
                  int main()
                  {
                  queue<int> x;
                  int a;
                  int b;
                  scanf("%d%d",&a,&b);
                  int count = 0;
                  number[a] = 0;
                  x.push(a);
                  while (x.size())
                  {
                  int y = x.front();
                  x.pop();
                  num[y] = 1;
                  if (y == b)
                  {
                  break;
                  }
                  else
                  {
                  if (y - 1 >= 0)
                  {
                  if (!num[y - 1])
                  {
                  x.push(y - 1);
                  number[y - 1] = number[y] + 1;
                  num[y - 1] = 1;
                  }
                  }
                  if (y + 1 <= 100000)
                  {
                  if (!num[y + 1])
                  {
                  x.push(y + 1);
                  number[y + 1] = number[y] + 1;
                  num[y + 1] = 1;
                  }
                  }
                  if (y * 2 <= 100000)
                  {
                  if (!num[y * 2])
                  {
                  x.push(y * 2);
                  number[y * 2] = number[y] + 1;
                  num[y * 2] = 1;
                  }
                  }
                  }
                  }
                  cout << number[b] << endl;
                  return 0;
                  }
            posted @ 2009-03-07 18:33 生活要低調 閱讀(1800) | 評論 (0)編輯 收藏
                 摘要: 這題沒把我弄瘋了.一個小時寫完,改了2個小時...題目給的數據太弱了,需要自己寫一些數據來驗證...在這里給大家提供些數據題目 Maze Time Limit: 2000MS Memory Limit: 65536K ...  閱讀全文
            posted @ 2009-03-07 15:14 生活要低調 閱讀(1237) | 評論 (0)編輯 收藏
            僅列出標題  
            <2025年5月>
            27282930123
            45678910
            11121314151617
            18192021222324
            25262728293031
            1234567

            常用鏈接

            留言簿(1)

            隨筆檔案

            搜索

            •  

            最新評論

            閱讀排行榜

            評論排行榜

            欧美久久久久久| 久久亚洲精品国产精品婷婷| 2020久久精品国产免费| 久久久久青草线蕉综合超碰| 国内精品伊人久久久久av一坑 | 久久国产视屏| 狠狠色噜噜色狠狠狠综合久久| 精品久久久久久无码专区 | 精品免费久久久久国产一区| 综合久久一区二区三区| 99国产精品久久| 久久久久精品国产亚洲AV无码| 日本久久久久久中文字幕| 久久久久久久精品妇女99| 免费观看成人久久网免费观看| 久久精品国产日本波多野结衣| 精品久久久久久无码国产| 青草国产精品久久久久久| 色婷婷综合久久久久中文字幕| 欧美久久综合性欧美| 麻豆亚洲AV永久无码精品久久| 性欧美大战久久久久久久| 国产精品久久久久久久午夜片| 东京热TOKYO综合久久精品| 久久久久免费精品国产| 伊人久久大香线蕉综合网站| 久久精品无码一区二区app| 国产欧美一区二区久久| 五月丁香综合激情六月久久| 久久人妻AV中文字幕| 亚洲国产成人久久笫一页| 国产日韩欧美久久| 99热精品久久只有精品| 精品无码久久久久久久久久| 国产高潮国产高潮久久久91| 久久综合欧美成人| 精品久久久无码中文字幕| 香蕉久久AⅤ一区二区三区| 中文字幕无码久久精品青草| 思思久久精品在热线热| 伊人久久精品无码av一区|