• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>
            posts - 3,  comments - 1,  trackbacks - 0
              2009年3月8日
                 摘要: 第N道的廣搜,這幾天就準備做廣搜了...真的需要好好練習下... Prime Path Time Limit: 1000MS Memory Limit: 65536K Total Submissions: 187...  閱讀全文
            posted @ 2009-03-08 11:23 生活要低調 閱讀(1441) | 評論 (1)編輯 收藏
              2009年3月7日
            學會了隊列.這道題的主要思想:

            5先入列   把5出列  5 可以變成 4 ,6 , 10, ,把得到的數入列,然后再出列分別處理..如果前面出現過就不入列..定義一個計數數組,然后number[y - 1] = number[y] + 1;  number[y + 1] = number[y] + 1; number[y * 2] = number[y] + 1;

            Catch That Cow
            Time Limit: 2000MS Memory Limit: 65536K
            Total Submissions: 8341 Accepted: 2476

            Description

            Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

            * Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
            * Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

            If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

            Input

            Line 1: Two space-separated integers: N and K

            Output

            Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

            Sample Input

            5 17

            Sample Output

            4

            Hint

            The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.




            Source Code

            Problem: 3278 User: luoguangyao
            Memory: 1048K Time: 110MS
            Language: C++ Result: Accepted
            • Source Code
              #include <iostream>
                  #include <queue>
                  using namespace::std;
                  int number[100001] = {0};
                  bool num[100001] = {0};
                  int main()
                  {
                  queue<int> x;
                  int a;
                  int b;
                  scanf("%d%d",&a,&b);
                  int count = 0;
                  number[a] = 0;
                  x.push(a);
                  while (x.size())
                  {
                  int y = x.front();
                  x.pop();
                  num[y] = 1;
                  if (y == b)
                  {
                  break;
                  }
                  else
                  {
                  if (y - 1 >= 0)
                  {
                  if (!num[y - 1])
                  {
                  x.push(y - 1);
                  number[y - 1] = number[y] + 1;
                  num[y - 1] = 1;
                  }
                  }
                  if (y + 1 <= 100000)
                  {
                  if (!num[y + 1])
                  {
                  x.push(y + 1);
                  number[y + 1] = number[y] + 1;
                  num[y + 1] = 1;
                  }
                  }
                  if (y * 2 <= 100000)
                  {
                  if (!num[y * 2])
                  {
                  x.push(y * 2);
                  number[y * 2] = number[y] + 1;
                  num[y * 2] = 1;
                  }
                  }
                  }
                  }
                  cout << number[b] << endl;
                  return 0;
                  }
            posted @ 2009-03-07 18:33 生活要低調 閱讀(1799) | 評論 (0)編輯 收藏
                 摘要: 這題沒把我弄瘋了.一個小時寫完,改了2個小時...題目給的數據太弱了,需要自己寫一些數據來驗證...在這里給大家提供些數據題目 Maze Time Limit: 2000MS Memory Limit: 65536K ...  閱讀全文
            posted @ 2009-03-07 15:14 生活要低調 閱讀(1237) | 評論 (0)編輯 收藏
            僅列出標題  
            <2025年5月>
            27282930123
            45678910
            11121314151617
            18192021222324
            25262728293031
            1234567

            常用鏈接

            留言簿(1)

            隨筆檔案

            搜索

            •  

            最新評論

            閱讀排行榜

            評論排行榜

            99久久久精品免费观看国产| 72种姿势欧美久久久久大黄蕉| 99久久精品无码一区二区毛片 | 精品久久久久久99人妻| 国产日韩欧美久久| 久久久久亚洲国产| 久久午夜电影网| 一个色综合久久| 亚洲国产精品一区二区久久| 武侠古典久久婷婷狼人伊人| 久久99国产综合精品免费| 久久久久久久综合综合狠狠| 无码国内精品久久人妻蜜桃| 国内精品久久久久久久久| 亚洲AV日韩AV永久无码久久| 久久se精品一区二区影院| 国产精品久久午夜夜伦鲁鲁| 亚洲精品97久久中文字幕无码| 久久精品中文字幕无码绿巨人| 亚洲国产精品嫩草影院久久 | 国产成人精品久久| 狠狠人妻久久久久久综合| 久久人妻少妇嫩草AV无码专区| 欧美与黑人午夜性猛交久久久| 99久久99这里只有免费费精品| 香港aa三级久久三级老师2021国产三级精品三级在 | 久久影院综合精品| 久久伊人五月丁香狠狠色| 少妇久久久久久被弄到高潮| 久久亚洲综合色一区二区三区| 久久亚洲AV成人出白浆无码国产| 亚洲国产成人精品久久久国产成人一区二区三区综 | 午夜视频久久久久一区| 久久国产精品无码网站| 国产精品无码久久四虎| 国产综合成人久久大片91| 国产精品嫩草影院久久| 久久久黄片| 中文字幕无码久久人妻| 久久亚洲精品国产亚洲老地址| 亚洲精品成人久久久|