• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>
            posts - 3,  comments - 1,  trackbacks - 0
              2009年3月8日
                 摘要: 第N道的廣搜,這幾天就準(zhǔn)備做廣搜了...真的需要好好練習(xí)下... Prime Path Time Limit: 1000MS Memory Limit: 65536K Total Submissions: 187...  閱讀全文
            posted @ 2009-03-08 11:23 生活要低調(diào) 閱讀(1441) | 評(píng)論 (1)編輯 收藏
              2009年3月7日
            學(xué)會(huì)了隊(duì)列.這道題的主要思想:

            5先入列   把5出列  5 可以變成 4 ,6 , 10, ,把得到的數(shù)入列,然后再出列分別處理..如果前面出現(xiàn)過(guò)就不入列..定義一個(gè)計(jì)數(shù)數(shù)組,然后number[y - 1] = number[y] + 1;  number[y + 1] = number[y] + 1; number[y * 2] = number[y] + 1;

            Catch That Cow
            Time Limit: 2000MS Memory Limit: 65536K
            Total Submissions: 8341 Accepted: 2476

            Description

            Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

            * Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
            * Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

            If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

            Input

            Line 1: Two space-separated integers: N and K

            Output

            Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

            Sample Input

            5 17

            Sample Output

            4

            Hint

            The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.




            Source Code

            Problem: 3278 User: luoguangyao
            Memory: 1048K Time: 110MS
            Language: C++ Result: Accepted
            • Source Code
              #include <iostream>
                  #include <queue>
                  using namespace::std;
                  int number[100001] = {0};
                  bool num[100001] = {0};
                  int main()
                  {
                  queue<int> x;
                  int a;
                  int b;
                  scanf("%d%d",&a,&b);
                  int count = 0;
                  number[a] = 0;
                  x.push(a);
                  while (x.size())
                  {
                  int y = x.front();
                  x.pop();
                  num[y] = 1;
                  if (y == b)
                  {
                  break;
                  }
                  else
                  {
                  if (y - 1 >= 0)
                  {
                  if (!num[y - 1])
                  {
                  x.push(y - 1);
                  number[y - 1] = number[y] + 1;
                  num[y - 1] = 1;
                  }
                  }
                  if (y + 1 <= 100000)
                  {
                  if (!num[y + 1])
                  {
                  x.push(y + 1);
                  number[y + 1] = number[y] + 1;
                  num[y + 1] = 1;
                  }
                  }
                  if (y * 2 <= 100000)
                  {
                  if (!num[y * 2])
                  {
                  x.push(y * 2);
                  number[y * 2] = number[y] + 1;
                  num[y * 2] = 1;
                  }
                  }
                  }
                  }
                  cout << number[b] << endl;
                  return 0;
                  }
            posted @ 2009-03-07 18:33 生活要低調(diào) 閱讀(1800) | 評(píng)論 (0)編輯 收藏
                 摘要: 這題沒(méi)把我弄瘋了.一個(gè)小時(shí)寫完,改了2個(gè)小時(shí)...題目給的數(shù)據(jù)太弱了,需要自己寫一些數(shù)據(jù)來(lái)驗(yàn)證...在這里給大家提供些數(shù)據(jù)題目 Maze Time Limit: 2000MS Memory Limit: 65536K ...  閱讀全文
            posted @ 2009-03-07 15:14 生活要低調(diào) 閱讀(1237) | 評(píng)論 (0)編輯 收藏
            僅列出標(biāo)題  
            <2025年5月>
            27282930123
            45678910
            11121314151617
            18192021222324
            25262728293031
            1234567

            常用鏈接

            留言簿(1)

            隨筆檔案

            搜索

            •  

            最新評(píng)論

            閱讀排行榜

            評(píng)論排行榜

            丁香五月网久久综合| 久久免费看黄a级毛片| 91精品观看91久久久久久| 99久久国产主播综合精品| 日本高清无卡码一区二区久久| 久久久久国产一区二区三区| 国内精品久久久久影院薰衣草| av无码久久久久久不卡网站| 精品久久人人妻人人做精品| 亚洲AV无码久久| 久久精品国产欧美日韩| 久久天天躁狠狠躁夜夜avapp| 久久www免费人成看国产片| 亚洲精品国产美女久久久| 国产亚州精品女人久久久久久 | 91亚洲国产成人久久精品| 久久天天躁狠狠躁夜夜2020老熟妇 | 最新久久免费视频| 久久青草国产手机看片福利盒子| 四虎久久影院| 亚洲一区中文字幕久久| 久久SE精品一区二区| 精品久久久久中文字| 国产精品9999久久久久| 国内精品九九久久精品| 久久久久无码精品| 国产ww久久久久久久久久| 国产精品久久久天天影视| 亚洲国产精品无码久久一线| 久久久久久久久久免免费精品| 久久精品成人国产午夜| 久久99久久99精品免视看动漫| 久久AV高潮AV无码AV| 久久综合亚洲色HEZYO社区| 香蕉久久影院| 中文字幕无码久久人妻| 亚洲第一永久AV网站久久精品男人的天堂AV | 中文字幕乱码人妻无码久久| 香蕉久久夜色精品国产2020| 久久av高潮av无码av喷吹| 99久久国产主播综合精品|