• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>
            付翔的專欄
            在鄙視中成長 記錄成長的點滴
            posts - 106,  comments - 32,  trackbacks - 0

            LC-Display



            A friend of yours has just bought a new computer. Before this, the most powerful machine he ever used was a pocket calculator. He is a little disappointed because he liked the LCD display of his calculator more than the screen on his new computer! To make him happy, write a program that prints numbers in LCD display style.

            Input

            The input file contains several lines, one for each number to be displayed. Each line contains integers s and n, where n is the number to be displayed ( 0$ \le$n$ \le$99, 999, 999) and s is the size in which it shall be displayed ( 1$ \le$s$ \le$10). The input will be terminated by a line containing two zeros, which should not be processed.

            Output

            Print the numbers specified in the input file in an LCD display-style using s ``-'' signs for the horizontal segments and s ``|'' signs for the vertical ones. Each digit occupies exactly s + 2 columns and 2s + 3 rows. Be sure to fill all the white space occupied by the digits with blanks, including the last digit. There must be exactly one column of blanks between two digits.

            Output a blank line after each number. You will find an example of each digit in the sample output below.

            Sample Input

            2 12345
            3 67890
            0 0

            Sample Output

                  --   --        -- 
            | | | | | |
            | | | | | |
            -- -- -- --
            | | | | |
            | | | | |
            -- -- --

            --- --- --- --- ---
            | | | | | | | |
            | | | | | | | |
            | | | | | | | |
            --- --- ---
            | | | | | | | |
            | | | | | | | |
            | | | | | | | |
            --- --- --- ---




            #include <iostream>
            using namespace std;

             
            int display[10][7];
            void init ()
            {
                display[
            0][0]=display[0][1]=display[0][2]=display[0][4]=display[0][5]=display[0][6]=1;
                display[
            1][2]=display[1][5= 1;
                display[
            2][0]=display[2][2]=display[2][3]=display[2][4]=display[2][6]=1;
                display[
            3][0]=display[3][2]=display[3][3]=display[3][5]=display[3][6]=1;
                display[
            4][1]=display[4][2]=display[4][3]=display[4][5]=1;
                display[
            5][0]=display[5][1]=display[5][3]=display[5][5]=display[5][6]=1;
                display[
            6][0]=display[6][1]=display[6][3]=display[6][4]=display[6][5]=display[6][6]=1;
                display[
            7][0]=display[7][2]=display[7][5]=1;
                display[
            8][0]=display[8][1]=display[8][2]=display[8][3]=display[8][4]=display[8][5]=display[8][6]=1;
                display[
            9][0]=display[9][1]=display[9][2]=display[9][3]=display[9][5]=display[9][6]=1;
                
            }
            int fun(int row)
            {
                
            if(row == 1)
                    
            return 0;
                
            if(row == 2)
                    
            return 1;
                
            if(row ==3)
                    
            return 3;
                
            if(row == 4)
                    
            return 4;
                
            if(row == 5)
                    
            return 6;
                
            }
            void work(int s,int row,int n)
            {
                
            char temp[10],c;
                
            int len,i,j,ans,k;
                itoa(n,temp,
            10);
                len 
            = strlen(temp);
                
            if(row %2 ==1)
                {
                    ans 
            = fun(row);
                    
            //printf(" ");
                    for(i = 0; i < len ; i ++)
                    {
                        printf(
            " ");
                        
            //if(temp[i]-'0' != 1)
                        
            //{
                            for(j = 0 ; j < s; j ++)
                            {
                                
            if(display[temp[i]-'0'][ans]==1)
                                    printf(
            "-");
                                
            else printf(" ");
                            }    
                        
            //}
                        printf(" %c",(i == len-1)?'\n':' ');
                        
                        
                    }
                    
                }
                
                
            else if(row %2== 0)
                {
                    ans 
            = fun(row);
                    
            for(i = 0; i < s ; i ++)
                    {
                        
            for(j = 0 ; j < len; j ++)
                        {
                            
            if(display[temp[j]-'0'][ans]==1)
                                printf(
            "|");
                            
            else printf(" ");
                            
                            
            //if(temp[j]-'0' != 1)
                            
            //{
                                for(k = 0; k < s ; k ++)
                                    printf(
            " ");
                                
            //    for(j = 0 ; j < len; j ++)
                                
            //    {
                                if(display[temp[j]-'0'][ans+1]==1)
                                    printf(
            "|");
                                
            else printf(" ");
                            
            //}
                            if(j != len-1) printf(" ");
                        }
                        
            //    }
                        printf("\n");                
                        
                    }
                    
                }
            }
            void solve(int s,int n)
            {
                
            for(int i = 1; i <= 5; i ++)work(s,i,n);
            }

            int main()
            {
                
            //freopen("in.txt","r",stdin);
                int s,n;
                init();
                
            while(scanf("%d%d",&s,&n),s||n)
                {
                    solve(s,n);
                }
                
            return 0;
            }

            posted on 2010-07-22 18:13 付翔 閱讀(185) 評論(0)  編輯 收藏 引用 所屬分類: ACM 數據結構

            <2010年7月>
            27282930123
            45678910
            11121314151617
            18192021222324
            25262728293031
            1234567

            常用鏈接

            留言簿(2)

            隨筆分類

            隨筆檔案

            文章分類

            文章檔案

            CSDN - 我的blog地址

            博客

            搜索

            •  

            最新評論

            閱讀排行榜

            評論排行榜

            久久久久人妻一区精品| 精品一区二区久久久久久久网站| 久久久久人妻一区精品性色av| 亚洲欧洲精品成人久久曰影片| 国产亚洲精午夜久久久久久| 精品久久久久国产免费| 国内精品久久久久久麻豆 | 亚洲欧美成人久久综合中文网| A级毛片无码久久精品免费| 91精品国产91久久久久福利| 精品蜜臀久久久久99网站| 久久亚洲国产成人精品性色| 人妻少妇久久中文字幕| 色欲av伊人久久大香线蕉影院| 久久精品亚洲一区二区三区浴池 | 久久无码一区二区三区少妇| 91久久福利国产成人精品| 国产亚洲精午夜久久久久久 | 久久久久国产视频电影| 武侠古典久久婷婷狼人伊人| 一本久久知道综合久久| 久久久久久狠狠丁香| 久久久久99精品成人片三人毛片| 色综合久久88色综合天天 | 久久久久久免费视频| 99久久国产热无码精品免费| 国产91久久综合| 囯产精品久久久久久久久蜜桃| 99久久精品午夜一区二区| 久久99精品久久久久久齐齐 | 久久99精品国产麻豆蜜芽| 偷偷做久久久久网站| 国产精品美女久久久久| 婷婷久久综合| 久久久精品午夜免费不卡| 久久人人爽人人爽人人片AV东京热| 久久永久免费人妻精品下载| 久久精品国产72国产精福利| 性欧美大战久久久久久久久| 国产精品成人99久久久久91gav| 99久久99久久精品国产片果冻|