The Moronic Cowmpouter
Time Limit: 1000MS |
|
Memory Limit: 65536K |
Total Submissions: 1344 |
|
Accepted: 676 |
Description
Inexperienced in the digital arts, the cows tried to build a calculating engine (yes, it's a cowmpouter) using binary numbers (base 2) but instead built one based on base negative 2! They were quite pleased since numbers expressed in base −2 do not have a sign bit.
You know number bases have place values that start at 1 (base to the 0 power) and proceed right-to-left to base^1, base^2, and so on. In base −2, the place values are 1, −2, 4, −8, 16, −32, ... (reading from right to left). Thus, counting from 1 goes like this: 1, 110, 111, 100, 101, 11010, 11011, 11000, 11001, and so on.
Eerily, negative numbers are also represented with 1's and 0's but no sign. Consider counting from −1 downward: 11, 10, 1101, 1100, 1111, and so on.
Please help the cows convert ordinary decimal integers (range -2,000,000,000..2,000,000,000) to their counterpart representation in base −2.
Input
Line 1: A single integer to be converted to base −2
Output
Line 1: A single integer with no leading zeroes that is the input integer converted to base −2. The value 0 is expressed as 0, with exactly one 0.
Sample Input
-13
Sample Output
110111
Hint
Explanation of the sample:
Reading from right-to-left:
1*1 + 1*-2 + 1*4 + 0*-8 +1*16 + 1*-32 = -13
棰樼洰鐨勬剰鎬濆氨鏄浣犳妸涓涓暟杞崲涓?2榪涘埗錛?br>鍩烘湰鍘熺悊:
濡傛灉n涓哄鏁幫紝閭d箞鏈綅鑲畾涓?錛屽洜姝ゅ氨鍙互杞負姹?x-1)/-2 鐨勫瓙闂浜嗭紒 錛堥櫎浠?2鍙互綾繪瘮鍗佽繘鍒跺氨鑳界悊瑙d簡錛?br> 濡傛灉n涓哄伓鏁幫紝鏈綅蹇呬負0錛岀劧鍚庡啀杞負姹倄/-2鐨勫瓙闂錛?br>緇撴潫鏉′歡褰?n=1銆?br>鎬濊礬寰堢畝鍗曪紝浣嗘槸鏈変袱涓皬鏂歸潰瑕佹彁鎻愶紝涓瀹氳鑰冭檻n=0鐨勬儏鍐碉紝鎴戝氨鏄病鑰冭檻鑰屼竴鐩磋秴鏃訛紝閮侀椃錛岃繕鎵句笉鍑洪敊璇紝闄峰叆浜嗘寰幆鎬笉寰楄秴鏃訛紝榪樻湁娉ㄦ剰鐞冪殑緇撴灉鏄嗗簭鐨勶紒錛佸懙鍛典笅闈㈡槸浠g爜錛?br>
1
//============================================================================
2
// Name : poj 3191.cpp
3
// Author : worm
4
// Copyright : Your copyright notice
5
// Description :鎶婁竴涓崄榪涘埗鐨勬暟杞崲涓?2榪涘埗鐨勬暟
6
//============================================================================
7
8
#include <iostream>
9
#include <stdio.h>
10
#include <string>
11
#include <math.h>
12
using namespace std;
13
string a= "";
14
int main()
{
15
int x;
16
cin >> x;
17
if (x == 0)
{
18
cout <<"0"<<endl;
19
return 0;
20
}
21
22
while (x != 1)
{
23
if (abs(x) % 2 == 1)
{
24
a += '1';
25
x = (x-1)/-2;
26
continue;
27
}
28
a += '0';
29
x /= -2;
30
}
31
cout <<"1";
32
for (int i = a.length() - 1; i >= 0; i--)
{
33
printf("%c",a[i]);
34
}
35
36
return 0;
37
}
38

]]>